{"id":59474,"date":"2025-10-07T17:00:00","date_gmt":"2025-10-07T17:00:00","guid":{"rendered":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/?p=142923"},"modified":"2025-10-07T17:00:00","modified_gmt":"2025-10-07T17:00:00","slug":"disrupting-threats-targeting-microsoft-teams","status":"publish","type":"post","link":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/","title":{"rendered":"Disrupting threats targeting Microsoft Teams"},"content":{"rendered":"<p class=\"wp-block-paragraph\">The extensive collaboration features and global adoption of Microsoft Teams make it a high-value target for both cybercriminals and state-sponsored actors. Threat actors abuse its core capabilities \u2013 messaging (chat), calls and meetings, and video-based screen-sharing \u2013 at different points along the attack chain. This raises the stakes for defenders to proactively monitor, detect, and respond.<\/p>\n<p class=\"wp-block-paragraph\">While under Microsoft\u2019s <a href=\"https:\/\/www.microsoft.com\/en-us\/trust-center\/security\/secure-future-initiative\">Secure Future Initiative<\/a> (SFI), default security has been strengthened by design, defenders still need to make the most out of customer-facing security capabilities. Therefore, this blog recommends countermeasures and controls across identity, endpoints, data apps, and network layers to help harden enterprise Teams environments. To frame these defenses, we first examine relevant stages of the attack chain. This guidance complements, but doesn\u2019t repeat, the guidance built into the&nbsp;<a href=\"https:\/\/www.microsoft.com\/sdl\/default.aspx\">Microsoft Security Development Lifecycle (SDL)<\/a>&nbsp;as outlined in the&nbsp;<a href=\"https:\/\/learn.microsoft.com\/microsoftteams\/teams-security-guide\">Teams Security Guide<\/a>; &nbsp;we will instead focus on guidance for disrupting adversarial objectives based on the relatively recently observed attempts to exploit Teams infrastructure and capabilities.<\/p>\n<h2 class=\"wp-block-heading\" id=\"attack-chain\">Attack chain<\/h2>\n<figure class=\"wp-block-image size-full\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/10\/Teams-threats-attack-chain.webp\" alt=\"Diagram showing the stages of attack and relevant attacker behavior abusing Microsoft Teams features \" class=\"wp-image-142925 webp-format\" srcset data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/10\/Teams-threats-attack-chain.webp\"><figcaption class=\"wp-element-caption\">Figure 1. Attack techniques that abuse Teams along the attack chain<\/figcaption><\/figure>\n<h3 class=\"wp-block-heading\" id=\"reconnaissance\">Reconnaissance<\/h3>\n<p class=\"wp-block-paragraph\">Every Teams user account is backed by a Microsoft Entra ID <a href=\"https:\/\/learn.microsoft.com\/microsoftteams\/identify-models-authentication\">identity<\/a>. Each team member is an Entra ID <a href=\"https:\/\/learn.microsoft.com\/entra\/identity\/hybrid\/cloud-sync\/concept-attributes\">object<\/a>, and a team is a collection of channel objects. Teams may be configured for the cloud or a hybrid environment and supports <a href=\"https:\/\/techcommunity.microsoft.com\/t5\/microsoft-teams-blog\/announcing-more-seamless-collaboration-in-microsoft-teams-for\/ba-p\/3901092\">multi-tenant organizations (MTO)<\/a>&nbsp;and <a href=\"https:\/\/support.microsoft.com\/office\/manage-accounts-and-organizations-in-microsoft-teams-7b221128-6643-465c-a317-679e48cd2ce9\">cross-tenant<\/a> communication and collaboration. There are <a href=\"https:\/\/learn.microsoft.com\/microsoftteams\/anonymous-users-in-meetings\">anonymous<\/a> participants, <a href=\"https:\/\/learn.microsoft.com\/MicrosoftTeams\/guest-access\">guests<\/a>, and <a href=\"https:\/\/learn.microsoft.com\/microsoftteams\/manage-external-access\">external access<\/a> users. From an API perspective, Teams is an object type that can be queried and stored in a local database for reconnaissance by enumerating directory objects, and mapping relationships and privileges. For example, <a href=\"https:\/\/learn.microsoft.com\/powershell\/module\/teams\/set-cstenantfederationconfiguration?view=teams-ps\">federation tenant configuration<\/a> indicates whether the tenant allows external communication and can be inferred from the API response queries reflecting the effective tenant federation policy.<\/p>\n<p class=\"wp-block-paragraph\">While not unique to Teams, there are open-source frameworks that can specifically be leveraged to enumerate less secure users, groups, and tenants in Teams (mostly by repurposing the <a href=\"https:\/\/learn.microsoft.com\/graph\/use-the-api\">Microsoft Graph API<\/a> or gathering DNS), including ROADtools, TeamFiltration, <a href=\"https:\/\/github.com\/sse-secure-systems\/TeamsEnum#readme-ov-file\">TeamsEnum<\/a>, and <a href=\"https:\/\/github.com\/copyleftdev\/msft-recon-rs\">MSFT-Recon-RS<\/a>. These tools facilitate enumerating teams, members of teams and channels, tenant IDs and enabled domains, as well as permissiveness for communicating with external organizations and other properties, like presence. <a href=\"https:\/\/learn.microsoft.com\/microsoftteams\/presence-admins#presence-states-in-teams\">Presence<\/a> indicates a user\u2019s current availability and status outside the organization if Privacy mode is not enabled, which could then be exploited if the admin has not <a href=\"https:\/\/learn.microsoft.com\/microsoftteams\/trusted-organizations-external-meetings-chat?tabs=organization-settings\">disabled<\/a> external meetings and chat with people and organizations outside the organization (or at least limited it to specified external domains).<\/p>\n<p class=\"wp-block-paragraph\">Many open-source tools are modular Python packages including reusable libraries and classes that can be directly imported or extended to support custom classes, meaning they are also interoperable with other custom open-source reconnaissance and discovery frameworks designed to identify potential misconfigurations.<\/p>\n<h3 class=\"wp-block-heading\" id=\"resource-development\">Resource development<\/h3>\n<p class=\"wp-block-paragraph\">Microsoft continuously enhances protections against fraudulent Microsoft Entra ID Workforce tenants and the abuse of free tenants and trial subscriptions. As these defenses grow stronger, threat actors are forced to invest significantly more resources in their attempts to impersonate trusted users, demonstrating the effectiveness of our layered security approach. . This includes threat actors trying to compromise weakly configured legitimate tenants, or even actually purchasing legitimate ones if they have confidence they could ultimately profit. It should come as no surprise that if they can build a persona for social engineering, they will take advantage of the same resources as legitimate organizations, including <a href=\"https:\/\/learn.microsoft.com\/entra\/fundamentals\/add-custom-domain\">custom domains<\/a> and <a href=\"https:\/\/learn.microsoft.com\/en-us\/entra\/fundamentals\/how-to-customize-branding\">branding<\/a>, especially if it can lend credibility to impersonating internal help desk, admin, or IT support, which could then be used as a convincing pretext to compromise targets through chat messaging and phone calls. Sophisticated threat actors try to use the very same resources used by trustworthy organizations, such as acquiring multiple tenants for staging development or running separate operations across regions, and using everyday Teams features like scheduling private meetings through chat, and audio, video and screen-sharing capabilities for productivity.<\/p>\n<h3 class=\"wp-block-heading\" id=\"initial-access\">Initial access<\/h3>\n<p class=\"wp-block-paragraph\">Tech support scams remain a generally popular pretext for delivery of malicious <a href=\"https:\/\/techcommunity.microsoft.com\/blog\/microsoftsecurityexperts\/keys-to-the-kingdom-rmm-exploits-enabling-human-operated-intrusions-in-2024%E2%80%9325\/4410903\">remote monitoring and management<\/a> (RMM) tools and information-stealing malware, <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2024\/05\/15\/threat-actors-misusing-quick-assist-in-social-engineering-attacks-leading-to-ransomware\">leading<\/a> to credential theft, extortion, and <a href=\"https:\/\/learn.microsoft.com\/security\/ransomware\/human-operated-ransomware\">ransomware<\/a>. There are always new variants to bypass security awareness defenses, such as the rise in <a href=\"https:\/\/techcommunity.microsoft.com\/blog\/microsoftdefenderforoffice365blog\/protection-against-email-bombs-with-microsoft-defender-for-office-365\/4418048\">email bombing<\/a> to create a sense of stress and urgency to restore normalcy. In 2024, for instance, Storm-1811 impersonated tech support, claiming to be addressing junk email issues that it had initiated. They used RMM tools to deliver the ReedBed malware loader of ransomware payloads and remote command execution. Meanwhile, Midnight Blizard has successfully impersonated security and technical support teams to get targets to verify their identities under the pretext of protecting their accounts by entering authentication codes that complete the authentication flow for breaking into the accounts.<\/p>\n<p class=\"wp-block-paragraph\">Similarly in May, Sophos <a href=\"https:\/\/news.sophos.com\/en-us\/2025\/05\/20\/a-familiar-playbook-with-a-twist-3am-ransomware-actors-dropped-virtual-machine-with-vishing-and-quick-assist\/\">identified<\/a> a 3AM ransomware (believed to be a rebranding of <a href=\"https:\/\/www.cisa.gov\/news-events\/cybersecurity-advisories\/aa23-061a\">BlackSuit<\/a>) affiliate adopting techniques from <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2024\/05\/15\/threat-actors-misusing-quick-assist-in-social-engineering-attacks-leading-to-ransomware\">Storm-1811<\/a>, including flooding employees with unwanted emails followed by voice and video calls on Teams impersonating help desk personnel, claiming they needed remote access to stop the flood of junk emails. The threat actor reportedly spoofed the IT organization\u2019s phone number.<\/p>\n<p class=\"wp-block-paragraph\">With threat actors leveraging <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2025\/04\/16\/cyber-signals-issue-9-ai-powered-deception-emerging-fraud-threats-and-countermeasures\/\">deepfakes<\/a>, perceived authority helps make this kind of social engineering even more effective. Threat actors seeking to spoof automated workflow notifications and interactions can naturally extend to spoofing legitimate bots and agents as they gain more traction, as threat actors are turning to language models to facilitate their objectives.<\/p>\n<p class=\"wp-block-paragraph\">Prevalent threat actors associated with ransomware campaigns, including the access broker tracked as Storm-1674 have used sophisticated red teaming tools, like <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2023\/12\/28\/financially-motivated-threat-actors-misusing-app-installer\">TeamsPhisher<\/a>, to distribute DarkGate malware and other malicious payloads over Teams. In December 2024, for example, Trend Micro <a href=\"https:\/\/www.trendmicro.com\/en_us\/research\/24\/l\/darkgate-malware.html\">reported<\/a> an incident in which a threat actor impersonated a client during a Teams call to persuade a target to install AnyDesk. Remote access was reportedly then used also to deploy DarkGate. Threat actors may also just use Teams to gain initial access through drive-by-compromise activity to direct users to malicious websites.<\/p>\n<p class=\"wp-block-paragraph\">Widely available admin tools, including <a href=\"https:\/\/aadinternals.com\/aadinternals\/#about\">AADInternals<\/a>, could be leveraged to deliver malicious links and payloads directly into Teams. Teams branding (like any communications brand asset) makes for effective bait, and has been used by <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2025\/05\/29\/defending-against-evolving-identity-attack-techniques\/\">adversary-in-the-middle (AiTM) actors like Storm-00485<\/a>. Threat actors could place malicious advertisements in search results for a spoofed app like Teams to misdirect users to a download site hosting credential-stealing malware. In July 2025, for instance, Malwarebytes <a href=\"https:\/\/www.malwarebytes.com\/blog\/threat-intelligence\/2024\/07\/fake-microsoft-teams-for-mac-delivers-atomic-stealer\">reported<\/a> observing a malvertising campaign delivering credential-stealing malware through a fake Microsoft Teams for Mac installer.<\/p>\n<p class=\"wp-block-paragraph\">Whether it is a core app that is part of Teams, an app created by Microsoft, a partner app validated by Microsoft, or a custom app created by your own organization\u2014no matter how secure an app\u2014they could still be spoofed to gain a foothold in a network. And similar to leveraging a trusted brand like Teams, threat actors will also continue to try and take advantage of trusted relationships as well to gain Teams access, whether leveraging an account with access or abusing delegated administrator relationships to reach a target environment.<\/p>\n<h3 class=\"wp-block-heading\" id=\"persistence\">Persistence<\/h3>\n<p class=\"wp-block-paragraph\">Threat actors employ a variety of persistence techniques to maintain access to target systems\u2014even after defenders attempt to regain control. These methods include abusing shortcuts in the Startup folder to execute malicious tools, or exploiting accessibility features like Sticky Keys (as seen in this ransomware <a href=\"https:\/\/learn.microsoft.com\/security\/ransomware\/dart-ransomware-case-study\">case study<\/a>). Threat actors could try to create guest users in target tenants or add their own credentials to a Teams account to maintain access.<\/p>\n<p class=\"wp-block-paragraph\">Part of the reason device code phishing has been used to access target accounts is that it could enable persistent access for as long as the tokens remain valid. In February, Microsoft <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2025\/02\/13\/storm-2372-conducts-device-code-phishing-campaign\/\">reported<\/a> that Storm-2372 had been capturing authentication tokens by exploiting device code authentication flows, partially by masquerading as Microsoft Teams meeting invitations and initiating Teams chats to build rapport, so that when the targets were prompted to authenticate, they would use Storm-2372-generated device codes, enabling Storm-2372 to steal the authenticated sessions from the valid access tokens.<\/p>\n<p class=\"wp-block-paragraph\">Teams phishing lures themselves can sometimes be a disguised attempt to help threat actors maintain persistence. For example, in July 2025, the financially motivated Storm-0324 most likely relied on TeamsPhisher to send Teams phishing lures to deliver a custom malware JSSloader for the ransomware operator Sangria Tempest to use as an access vector to maintain a foothold.<\/p>\n<h3 class=\"wp-block-heading\" id=\"execution\">Execution<\/h3>\n<p class=\"wp-block-paragraph\">Apart from admin accounts, which are an attractive target because they come with elevated privileges, threat actors try and trick everyday Teams users into clicking links or opening files that lead to malicious code execution, just like through email.<\/p>\n<h3 class=\"wp-block-heading\" id=\"privilege-escalation\">Privilege escalation<\/h3>\n<p class=\"wp-block-paragraph\">If threat actors successfully compromise accounts or register actor-controlled devices, they often times &nbsp;try to change permission groups to escalate privileges.<strong> <\/strong>If a threat actor successfully compromises a Teams admin role, this could lead to abuse of the permissions to use the admin tools that belong to that role.<\/p>\n<h3 class=\"wp-block-heading\" id=\"credential-access\">Credential access<\/h3>\n<p class=\"wp-block-paragraph\">With a valid refresh token, actors can impersonate users through Teams APIs. There is no shortage of administrator tools that can be maliciously repurposed, such as AADInternals, to intercept access to tokens with custom phishing flows. Tools like TeamFiltration could be leveraged just like for any other Microsoft 365 service for targeting Teams. If credentials are compromised through password spraying, threat actors use tools like this to request OAuth tokens for Teams and other services. Threat actors continue to try and bypass multifactor authentication (MFA) by repeatedly generating authentication prompts until someone accepts by mistake, and try to compromise MFA by adding alternate phone numbers or intercepting SMS-based codes.<\/p>\n<p class=\"wp-block-paragraph\">For instance, the financially motivated threat actor <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2025\/07\/16\/protecting-customers-from-octo-tempest-attacks-across-multiple-industries\/\" target=\"_blank\" rel=\"noreferrer noopener\">Octo Tempest<\/a> uses aggressive social engineering, including over Teams, to take control of MFA for privileged accounts. They consistently socially engineer help desk personnel, targeting federated identity providers using tools like AADInternals to federate existing domains, or spoof legitimate domains by adding and then federating new domains to forge tokens.<\/p>\n<h3 class=\"wp-block-heading\" id=\"discovery\">Discovery<\/h3>\n<p class=\"wp-block-paragraph\">To refine targeting, threat actors analyze Teams configuration data from API responses, enumerate Teams apps if they obtain unauthorized access, and search for valuable files and directories by leveraging toolkits for contextualizing potential attack paths. For instance, <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2025\/05\/27\/new-russia-affiliated-actor-void-blizzard-targets-critical-sectors-for-espionage\/\">Void Blizzard<\/a> has used AzureHound to enumerate a compromised organization\u2019s Microsoft Entra ID configuration and gather details on users, roles, groups, applications, and devices. In a small number of compromises, the threat actor accessed Teams conversations and messages through the web client. AADInternals can also be used to discover Teams group structures and permissions.<\/p>\n<p class=\"wp-block-paragraph\">The state-sponsored actor Peach Sandstorm has delivered malicious <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2024\/08\/28\/peach-sandstorm-deploys-new-custom-tickler-malware-in-long-running-intelligence-gathering-operations\/\">ZIP files<\/a> through Teams, then used <a href=\"https:\/\/learn.microsoft.com\/sysinternals\/downloads\/adexplorer\">AD Explorer<\/a> to take snapshots of on-premises Active Directory database and related files.<\/p>\n<h3 class=\"wp-block-heading\" id=\"lateral-movement\">Lateral movement<\/h3>\n<p class=\"wp-block-paragraph\">A threat actor that manages to obtain Teams admin access (whether directly or indirectly by purchasing an admin account through a rogue online marketplace) could potentially leverage external communication settings and enable trust relationships between organizations to move laterally. In late 2024, in a campaign dubbed <a href=\"https:\/\/www.hunters.security\/en\/blog\/veildrive-microsoft-services-malware-c2\">VEILdrive<\/a><em> <\/em>by Hunters\u2019 Team AXON, the financially motivated cybercriminal threat actors Sangria Tempest and Storm-1674 used previously compromised accounts to impersonate IT personnel and convince a user in another organization through Teams to accept a chat request and grant access through a remote connection.<\/p>\n<h3 class=\"wp-block-heading\" id=\"collection\">Collection<\/h3>\n<p class=\"wp-block-paragraph\">Threat actors often target Teams to try and collect information from it that could help them to accomplish their objectives, such as to discover collaboration channels or high-privileged accounts. They could try to mine Teams for any information perceived as useful in furtherance of their objectives, including pivoting from a compromised account to data accessible to that user from OneDrive or SharePoint. AADInternals can be used to collect sensitive chat data and user profiles. Post-compromise, <a href=\"https:\/\/github.com\/dafthack\/GraphRunner\">GraphRunner<\/a> can leverage the Microsoft Graph API to search all chats and channels and export Teams conversations.<\/p>\n<h3 class=\"wp-block-heading\" id=\"command-and-control\">Command and control<\/h3>\n<p class=\"wp-block-paragraph\">Threat actors attempt to deliver malware through file attachments in Teams chats or channels. A cracked version of Brute Ratel C4 (BRc4) includes features to establish C2 channels with platforms like Microsoft Teams by using their communications protocols to send and receive commands and data.<\/p>\n<p class=\"wp-block-paragraph\">Post-compromise, threat actors can use red teaming tool <a href=\"https:\/\/github.com\/cxnturi0n\/convoC2\">ConvoC2<\/a> to send commands through Microsoft Teams messages using the <a href=\"https:\/\/learn.microsoft.com\/microsoftteams\/platform\/task-modules-and-cards\/cards\/design-effective-cards?tabs=design\">Adaptive Card<\/a> framework to embed data in hidden span tags and then exfiltrate using webhooks. But threat actors can also use legitimate remote access tools to try and establish interactive C2 through Teams.<\/p>\n<h3 class=\"wp-block-heading\" id=\"exfiltration\">Exfiltration<\/h3>\n<p class=\"wp-block-paragraph\">Threat actors may use Teams messages or shared links to direct data exfiltration to cloud storage under their control. Tools like TeamFiltration include an exfiltration module that rely on a valid access token to then extract recent contacts and download chats and files through OneDrive or SharePoint.<\/p>\n<h3 class=\"wp-block-heading\" id=\"impact\">Impact<\/h3>\n<p class=\"wp-block-paragraph\">Threat actors try to use Teams messages to support financial theft through extortion, social engineering, or technical means.<\/p>\n<p class=\"wp-block-paragraph\">Octo Tempest has used communication apps, including Teams to send taunting and threatening messages to organizations, defenders, and incident response teams as part of extortion and ransomware payment pressure tactics. After gaining control of MFA through social engineering password resets, they sign in to Teams to identify sensitive information supporting their financially motivated operations.<\/p>\n<h2 class=\"wp-block-heading\" id=\"mitigation-and-protection-guidance\">Mitigation and protection guidance<\/h2>\n<h3 class=\"wp-block-heading\" id=\"strengthen-identity-protection\">Strengthen identity protection<\/h3>\n<h3 class=\"wp-block-heading\" id=\"harden-endpoint-security\">Harden endpoint security<\/h3>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Use <a href=\"https:\/\/learn.microsoft.com\/defender-office-365\/configuration-analyzer-for-security-policies\">configuration analyzer<\/a> to strengthen security posture. Identify and remediate security policies that are less secure than the Standard or Strict protection profiles in <a href=\"https:\/\/learn.microsoft.com\/defender-office-365\/preset-security-policies\">preset security policies<\/a>.<\/li>\n<li class=\"wp-block-list-item\">Keep Teams clients, browsers, OS, and dependencies <a href=\"https:\/\/learn.microsoft.com\/microsoftteams\/teams-client-update\">updated<\/a>.<\/li>\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/network-protection#overview-of-network-protection\">Enable network protection<\/a> and <a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/web-protection-overview\">web protection capability<\/a> in Defender for Endpoint.<\/li>\n<li class=\"wp-block-list-item\">Enable <a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/cloud-protection-microsoft-defender-antivirus\">cloud-delivered protection<\/a> in Defender Antivirus. Cloud-delivered protection enables sharing detection status between Microsoft 365 and Defender for Endpoint. <a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/configure-protection-features-microsoft-defender-antivirus\">Real-time protection blocking<\/a>, including on-access scanning, is not availablewhen Defender Antivirus is running only in passive mode. You can turn on <a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/edr-in-block-mode\">endpoint detection and response (EDR) in block mode<\/a> even if Defender Antivirus isn\u2019t your primary antivirus solution. EDR in block mode detects and remediates malicious items on the device post-breach.<\/li>\n<li class=\"wp-block-list-item\">Protect security settings from being disabled or changed with <a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/prevent-changes-to-security-settings-with-tamper-protection\">tamper protection<\/a>.<\/li>\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/learn.microsoft.com\/entra\/identity\/conditional-access\/policy-all-users-device-compliance\">Require device compliance policies with Conditional Access<\/a>. Enhance conditional access, to the extent available, with real-time enforcement through <a href=\"https:\/\/learn.microsoft.com\/entra\/identity\/conditional-access\/concept-continuous-access-evaluation#key-benefits\">Continuous Access Evaluation (CAE)<\/a>, so that user session revocation is enforced in near-real time. Teams is supported as a cloud app in Microsoft Entra, so that <a href=\"https:\/\/learn.microsoft.com\/entra\/identity\/conditional-access\/concept-conditional-access-cloud-apps#office-365\">conditional access policies apply<\/a> when a user signs in. The Teams desktop application supports <a href=\"https:\/\/learn.microsoft.com\/windows\/security\/threat-protection\/windows-defender-application-control\/applocker\/requirements-to-use-applocker\">AppLocker<\/a>, but we recommend <a href=\"https:\/\/learn.microsoft.com\/windows\/security\/application-security\/application-control\/app-control-for-business\/appcontrol-and-applocker-overview\">using App Control<\/a>, if feasible. Use Defender for Endpoint to <a href=\"https:\/\/learn.microsoft.com\/intune\/intune-service\/protect\/advanced-threat-protection\">enforce device compliance with Microsoft Intune<\/a>.<\/li>\n<li class=\"wp-block-list-item\">If your organization utilizes another remote support tool such as&nbsp;<a href=\"https:\/\/www.microsoft.com\/security\/business\/endpoint-management\/microsoft-intune-remote-help\">Remote Help<\/a>, disable or remove Quick Assist as a best practice, if it isn\u2019t used within your environment.<\/li>\n<li class=\"wp-block-list-item\">Understand and use <a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/attack-surface-reduction\" target=\"_blank\" rel=\"noreferrer noopener\">attack surface reduction<\/a> capabilities in your environment to prevent common techniques used in combination with Teams threat activity as part of your first line of defense. <\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\" id=\"secure-teams-clients-and-apps\">Secure Teams clients and apps<\/h3>\n<p class=\"wp-block-paragraph\">Implementing some of these recommendations will require <a href=\"https:\/\/learn.microsoft.com\/microsoftteams\/using-admin-roles#teams-roles-and-capabilities\">Teams Administrator permissions<\/a>.<\/p>\n<p class=\"wp-block-paragraph\"><strong>Protect sensitive data<\/strong><\/p>\n<p class=\"wp-block-paragraph\"><strong>Raise awareness<\/strong><\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Get started using <a href=\"https:\/\/learn.microsoft.com\/defender-office-365\/attack-simulation-training-get-started\">attack simulation training<\/a>. The Teams <a href=\"https:\/\/learn.microsoft.com\/defender-office-365\/attack-simulation-training-teams\">attack simulation training<\/a> is currently in private preview. Build organizational resilience by raising awareness of QR code phishing, deepfakes including voice, and about protecting your organization from <a href=\"https:\/\/support.microsoft.com\/windows\/protect-yourself-from-tech-support-scams-2ebf91bd-f94c-2a8a-e541-f5c800d18435\" target=\"_blank\" rel=\"noreferrer noopener\">tech support<\/a> and <a href=\"https:\/\/security.microsoft.com\/threatanalytics3\/bdf0d0c5-f5f3-435a-b4a1-6e3beb73b5b9\/analystreport\">ClickFix<\/a> scams.<\/li>\n<li class=\"wp-block-list-item\">Train developers to follow <a href=\"https:\/\/learn.microsoft.com\/graph\/best-practices-concept\">best practices<\/a> when working with the Microsoft Graph API. Apply these practices when detecting, defending against, and responding to malicious techniques targeting Teams. <\/li>\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/security.microsoft.com\/threatanalytics3\/a30d3a89-c61c-429e-9a44-007931931ba6\/analystreport\">Learn more<\/a> about some of the frequent initial access threats impacting SharePoint servers. SharePoint is a <a href=\"https:\/\/learn.microsoft.com\/SharePoint\/teams-connected-sites\">front end<\/a> for Microsoft Teams and an attractive target.<\/li>\n<\/ul>\n<p class=\"wp-block-paragraph\"><strong>Configure detection and response<\/strong><\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/learn.microsoft.com\/purview\/audit-log-enable-disable\">Verify the auditing status<\/a> of your organization in Microsoft Purview to make sure you can investigate incidents. In&nbsp;Threat Explorer, Content malware includes files detected by Safe Attachments for Teams, and <em>URL clicks<\/em> include all user clicks in Teams.<\/li>\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/learn.microsoft.com\/defender-office-365\/submissions-teams#user-reporting-settings-for-teams-messages\">Customize<\/a> how users report malicious messages, and then <a href=\"https:\/\/learn.microsoft.com\/defender-office-365\/submissions-teams#view-and-triage-user-reported-messages-in-teams\">view and triage<\/a> them.\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">If user reporting of messages is turned on in the Teams admin center, it also needs to be turned on in the Defender portal. We encourage you to submit user reported Teams messages to Microsoft <a href=\"https:\/\/learn.microsoft.com\/defender-office-365\/submissions-admin#submit-user-reported-messages-to-microsoft-for-analysis\">here<\/a>.<\/li>\n<\/ul>\n<\/li>\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/learn.microsoft.com\/purview\/audit-teams-audit-log-events\">Search the audit log<\/a> for events in Teams.\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Refer to the <a href=\"https:\/\/learn.microsoft.com\/purview\/audit-log-activities#microsoft-teams-activities\">table<\/a> listing the Microsoft Teams activities logged in the Microsoft 365 audit log. With the <a href=\"https:\/\/learn.microsoft.com\/office\/office-365-management-api\/office-365-management-activity-api-reference?toc=%2Fmicrosoft-365%2Fcompliance%2Ftoc.json&amp;bc=%2Fmicrosoft-365%2Fbreadcrumb%2Ftoc.json\">Office 365 Management Activity API<\/a>, you can retrieve information about user, admin, system, and policy actions and events including from Entra activity logs.<\/li>\n<\/ul>\n<\/li>\n<li class=\"wp-block-list-item\">Familiarize yourself with relevant advanced hunting schema and available tables.\n<ul>\n<li>Advanced hunting supports <a href=\"https:\/\/learn.microsoft.com\/defender-xdr\/advanced-hunting-query-builder\">guided<\/a>&nbsp;and&nbsp;<a href=\"https:\/\/learn.microsoft.com\/defender-xdr\/advanced-hunting-query-language\">advanced<\/a> modes. You can use the advanced hunting queries in the advanced hunting section to hunt with these tables for Teams-related threats.<\/li>\n<\/ul>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Several tables covering Teams-related threats are available in preview and populated by Defender for Office 365, including <a href=\"https:\/\/learn.microsoft.com\/defender-xdr\/advanced-hunting-messageevents-table\">MessageEvents<\/a>, <a href=\"https:\/\/learn.microsoft.com\/defender-xdr\/advanced-hunting-messagepostdeliveryevents-table\">MessagePostDeliveryEvents<\/a>, <a href=\"https:\/\/learn.microsoft.com\/defender-xdr\/advanced-hunting-messageurlinfo-table\">MessageUrlInfo<\/a>, and <a href=\"https:\/\/learn.microsoft.com\/defender-xdr\/advanced-hunting-urlclickevents-table\">UrlClickEvents<\/a>. These tables provide visibility into ZAP events and URLs in Teams messages, including allowed or blocked URL clicks in Teams clients. You can join these tables with others to gain more comprehensive insight into the progression of the attack chain and end-to-end threat activity. <\/li>\n<\/ul>\n<\/li>\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/learn.microsoft.com\/defender-cloud-apps\/connect-office-365\">Connect<\/a> Microsoft 365 to Microsoft Defender for Cloud Apps.\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">To hunt for Teams messages without URLs, use the <a href=\"https:\/\/learn.microsoft.com\/en-us\/defender-xdr\/advanced-hunting-cloudappevents-table\">CloudAppEvents<\/a> table, populated by Defender for Cloud Apps. This table also includes chat monitoring events, meeting and Teams call tracking, and behavioral analytics. To make sure advanced hunting tables are populated by Defender for Cloud Apps data, go to the Defender portal and select Settings &gt; Cloud apps &gt; App connectors. Then, in the Select Microsoft 365 components page, select the Microsoft 365 activities checkbox. Control Microsoft 365 with <a href=\"https:\/\/learn.microsoft.com\/defender-cloud-apps\/protect-office-365\">built-in policies and policy templates<\/a> to detect and notify you about potential threats.<\/li>\n<\/ul>\n<\/li>\n<li class=\"wp-block-list-item\">Create Defender for Cloud Apps <a href=\"https:\/\/learn.microsoft.com\/defender-cloud-apps\/policies-threat-protection\">threat detection policies<\/a>.\n<ul>\n<li>Many of the detection types enabled by default apply to Teams and do not require custom policy creation, including sign-ins from geographically distant locations in a short time, access from a country not previously associated with a user, unexpected admin actions, mass downloads, activity from anonymous IP addresses, or from a device flagged as malware-infected by Defender for Endpoint, as well as Oauth app abuse (when <a href=\"https:\/\/learn.microsoft.com\/defender-cloud-apps\/app-governance-get-started\">app governance is turned on<\/a>).<\/li>\n<\/ul>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Defender for Cloud Apps enables you to identify high-risk use and cloud security issues, detect abnormal user behavior, and prevent threats in your sanctioned cloud apps. You can i<a href=\"https:\/\/learn.microsoft.com\/defender-cloud-apps\/siem-sentinel\">ntegrate<\/a> Defender for Cloud Apps with Microsoft Sentinel (preview) or use the <a href=\"https:\/\/learn.microsoft.com\/defender-cloud-apps\/siem\">supported APIs<\/a>.<\/li>\n<\/ul>\n<\/li>\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/learn.microsoft.com\/defender-office-365\/detect-and-remediate-illicit-consent-grants\">Detect and remediate illicit consent grants<\/a> in Microsoft 365. <\/li>\n<li class=\"wp-block-list-item\">Discover and enable the <a href=\"https:\/\/learn.microsoft.com\/azure\/sentinel\/datalake\/sentinel-lake-overview\">Microsoft Sentinel data lake<\/a> in Defender XDR. Sentinel data lake brings together security logs from data sources like Microsoft Defender and Microsoft Sentinel, Microsoft 365, Microsoft Entra ID, Purview, Intune, Microsoft Resource Graph, firewall and network logs, identity and access logs, DNS, plus sources from hundreds of connectors and solutions, including <a href=\"https:\/\/learn.microsoft.com\/azure\/sentinel\/connect-mdti-data-connector\">Microsoft Defender Threat Intelligence<\/a>. Advanced hunting <a href=\"https:\/\/learn.microsoft.com\/azure\/sentinel\/datalake\/kql-queries\">KQL queries<\/a> can be run directly on the data lake. You can analyze the data <a href=\"https:\/\/learn.microsoft.com\/azure\/sentinel\/datalake\/notebook-examples\">using Jupyter notebooks<\/a>.<\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\" id=\"microsoft-defender-detections\">Microsoft Defender detections<\/h2>\n<p class=\"wp-block-paragraph\">Microsoft Defender XDR customers can refer to the list of applicable detections below. Microsoft Defender XDR coordinates detection, prevention, investigation, and response across endpoints, identities, email, apps to provide integrated protection against attacks like the threat discussed in this blog.<\/p>\n<p class=\"wp-block-paragraph\">Customers with provisioned access can also use <a href=\"https:\/\/learn.microsoft.com\/en-us\/defender-xdr\/security-copilot-in-microsoft-365-defender\">Microsoft Security Copilot in Microsoft Defender<\/a> to investigate and respond to incidents, hunt for threats, and protect their organization with relevant threat intelligence.<\/p>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-xdr\">Microsoft Defender XDR<\/h3>\n<p class=\"wp-block-paragraph\">The following alerts might indicate threat activity associated with this threat.<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Malicious sign in from a risky IP address<\/li>\n<li class=\"wp-block-list-item\">Malicious sign in from an unusual user agent<\/li>\n<li class=\"wp-block-list-item\">Account compromised following a password-spray attack<\/li>\n<li class=\"wp-block-list-item\">Compromised user account identified in Password Spray activity<\/li>\n<li class=\"wp-block-list-item\">Successful authentication after password spray attack<\/li>\n<li class=\"wp-block-list-item\">Password Spray detected via suspicious Teams client (TeamFiltration)<\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\" id=\"microsoft-entra-id-protection\">Microsoft Entra ID Protection<\/h3>\n<p class=\"wp-block-paragraph\">Any type of <a href=\"https:\/\/learn.microsoft.com\/en-us\/entra\/id-protection\/concept-identity-protection-risks#sign-in-risk-detections-mapped-to-riskeventtype\">sign-in and user risk detection<\/a> might also indicate threat activity associated with this threat. An example is listed below. These alerts, however, can be triggered by unrelated threat activity.<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Impossible travel<\/li>\n<li class=\"wp-block-list-item\">Anomalous Microsoft Teams login from web client<\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-for-endpoint\">Microsoft Defender for Endpoint<\/h3>\n<p class=\"wp-block-paragraph\">The following alerts might indicate threat activity associated with this threat.<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Suspicious module loaded using Microsoft Teams<\/li>\n<\/ul>\n<p class=\"wp-block-paragraph\">The following alerts might also indicate threat activity associated with this threat. These alerts, however, can be triggered by unrelated threat activity and are not monitored in the status cards provided with this report.<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Suspicious usage of remote management software<\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-for-office-365\">Microsoft Defender for Office 365<\/h3>\n<p class=\"wp-block-paragraph\">The following alerts might indicate threat activity associated with this threat.<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Malicious link shared in Teams chat<\/li>\n<li class=\"wp-block-list-item\">User clicked a malicious link in Teams chat<\/li>\n<\/ul>\n<p class=\"wp-block-paragraph\">When Microsoft Defender for Cloud Apps is enabled, the following alert might indicate threat activity associated with this threat.<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Potentially Malicious IT Support Teams impersonation post mail bombing<\/li>\n<\/ul>\n<p class=\"wp-block-paragraph\">The following alerts might also indicate threat activity associated with this threat. These alerts, however, can be triggered by unrelated threat activity and are not monitored in the status cards provided with this report.<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">A potentially malicious URL click was detected<\/li>\n<li class=\"wp-block-list-item\">Possible AiTM phishing attempt<\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-for-identity\">Microsoft Defender for Identity<\/h3>\n<p class=\"wp-block-paragraph\">The following Microsoft Defender for Identity alerts can indicate associated threat activity:<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Account enumeration reconnaissance<\/li>\n<li class=\"wp-block-list-item\">Suspicious additions to sensitive groups<\/li>\n<li class=\"wp-block-list-item\">Account Enumeration reconnaissance (LDAP)<\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-for-cloud-apps\">Microsoft Defender for Cloud Apps<\/h3>\n<p class=\"wp-block-paragraph\">The following alerts might indicate threat activity associated with this threat.<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Consent granted to application with Microsoft Teams permissions<\/li>\n<li class=\"wp-block-list-item\">Risky user installed a suspicious application in Microsoft Teams<\/li>\n<li class=\"wp-block-list-item\">Compromised&nbsp;account&nbsp;signed&nbsp;in&nbsp;to&nbsp;Microsoft&nbsp;Teams<\/li>\n<li class=\"wp-block-list-item\">Microsoft&nbsp;Teams&nbsp;chat&nbsp;initiated&nbsp;by&nbsp;a&nbsp;suspicious&nbsp;external&nbsp;user<\/li>\n<li class=\"wp-block-list-item\">Suspicious Teams access via Graph API<\/li>\n<\/ul>\n<p class=\"wp-block-paragraph\">The following alerts might also indicate threat activity associated with this threat. These alerts, however, can be triggered by unrelated threat activity and are not monitored in the status cards provided with this report.<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Possible mail exfiltration by app<\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\" id=\"microsoft-security-copilot\">Microsoft Security Copilot<\/h3>\n<p class=\"wp-block-paragraph\"><a href=\"https:\/\/learn.microsoft.com\/defender-xdr\/security-copilot-in-microsoft-365-defender\">Microsoft Security Copilot<\/a> customers can use the <a href=\"https:\/\/learn.microsoft.com\/en-us\/defender-xdr\/security-copilot-in-microsoft-365-defender\">Copilot in Defender embedded experience<\/a> to check the impact of this report and get insights based on their environment\u2019s highest exposure level in Threat analytics, Intel profiles, Intel Explorer and Intel projects pages of the Defender portal.<\/p>\n<p class=\"wp-block-paragraph\">You can also use Copilot in Defender to speed up <a href=\"https:\/\/learn.microsoft.com\/defender-xdr\/security-copilot-m365d-script-analysis\">analysis of suspicious scripts and command lines<\/a> by inspecting them below the incident graph on an incident page and in the timeline on the Device entity page without using external tools.<\/p>\n<h2 class=\"wp-block-heading\" id=\"threat-intelligence-reports\">Threat intelligence reports<\/h2>\n<p class=\"wp-block-paragraph\">Microsoft customers can use the following reports in Microsoft products to get the most up-to-date information about the threat actor, malicious activity, and techniques discussed in this blog. These reports provide the intelligence, protection information, and recommended actions to prevent, mitigate, or respond to associated threats found in customer environments.<\/p>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-xdr-threat-analytics\">Microsoft Defender XDR threat analytics<\/h3>\n<p class=\"wp-block-paragraph\">Microsoft Security Copilot customers can also use the <a href=\"https:\/\/learn.microsoft.com\/defender\/threat-intelligence\/security-copilot-and-defender-threat-intelligence?bc=%2Fsecurity-copilot%2Fbreadcrumb%2Ftoc.json&amp;toc=%2Fsecurity-copilot%2Ftoc.json#turn-on-the-security-copilot-integration-in-defender-ti\">Microsoft Security Copilot integration<\/a> in Microsoft Defender Threat Intelligence, either in the Security Copilot standalone portal or in the <a href=\"https:\/\/learn.microsoft.com\/defender\/threat-intelligence\/using-copilot-threat-intelligence-defender-xdr\">embedded experience<\/a> in the Microsoft Defender portal to get more information about this threat actor.<\/p>\n<h2 class=\"wp-block-heading\" id=\"hunting-queries\">Hunting queries<\/h2>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-xdr\">Microsoft Defender XDR<\/h3>\n<p class=\"wp-block-paragraph\">Advanced hunting allows you to view and query all the data sources available within the&nbsp;<a href=\"https:\/\/learn.microsoft.com\/defender-xdr\/microsoft-365-defender-portal\">unified Microsoft Defender portal<\/a>, which include Microsoft Defender XDR and various Microsoft security services.<\/p>\n<p class=\"wp-block-paragraph\">After onboarding to the Microsoft Sentinel data lake, auxiliary log tables are no longer available in Microsoft Defender advanced hunting. Instead, you can access them through data lake exploration Kusto Query Language (KQL) queries in the Defender portal. For more information, see&nbsp;<a href=\"https:\/\/learn.microsoft.com\/azure\/sentinel\/datalake\/kql-queries\">KQL queries in the Microsoft Sentinel data lake<\/a>.<\/p>\n<p class=\"wp-block-paragraph\">You can design and tweak <a href=\"https:\/\/learn.microsoft.com\/en-us\/defender-xdr\/custom-detection-rules\">custom detection rules<\/a> using the advanced hunting queries and set them to run at regular intervals, generating alerts and taking response actions whenever there are matches. You can also link the generated alert to this report so that it appears in the <a href=\"https:\/\/learn.microsoft.com\/en-us\/defender-xdr\/threat-analytics#set-up-custom-detections-and-link-them-to-threat-analytics-reports\">Related incidents<\/a> tab in threat analytics. Custom detection rule can automatically <a href=\"https:\/\/learn.microsoft.com\/en-us\/defender-xdr\/custom-detection-rules#4-specify-actions\">take actions<\/a> on devices, files, users, or emails that are returned by the query. To make sure you\u2019re creating detections that trigger true alerts, take time to review your existing custom detections by following the steps in&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/defender-xdr\/custom-detection-manage\">Manage existing custom detection rules<\/a>.<\/p>\n<p class=\"wp-block-paragraph\"><strong>Detect potential data exfiltration from Teams<\/strong><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"18\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nlet timeWindow = 1h; let messageThreshold = 20; let trustedDomains = dynamic([\"trustedpartner.com\", \"anothertrusted.com\"]); CloudAppEvents | where Timestamp &gt; ago(1d) | where ActionType == \"MessageSent\" | where Application == \"Microsoft Teams\" | where isnotempty(AccountObjectId)\n| where tostring(parse_json(RawEventData).ParticipantInfo.HasForeignTenantUsers) == \"true\" | where tostring(parse_json(RawEventData).CommunicationType) in (\"OneOnOne\", \"GroupChat\") | extend RecipientDomain = tostring(parse_json(RawEventData).ParticipantInfo.ParticipatingDomains[1])\n| where RecipientDomain !in (trustedDomains) | extend SenderUPN = tostring(parse_json(RawEventData).UserId)\n| summarize MessageCount = count() by bin(Timestamp, timeWindow), SenderUPN, RecipientDomain\n| where MessageCount &gt; messageThreshold | project Timestamp, MessageCount, SenderUPN, RecipientDomain\n| sort by MessageCount desc <\/pre>\n<\/div>\n<p class=\"wp-block-paragraph\"><strong>Detect mail bombing that sometimes precedes technical support scams on Microsoft Teams<\/strong><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"12\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nEmailEvents | where Timestamp &gt; ago(1d) | where DetectionMethods contains \"Mail bombing\" | project Timestamp, NetworkMessageId, SenderFromAddress, Subject, ReportId\n<\/pre>\n<\/div>\n<p class=\"wp-block-paragraph\"><strong>Detect malicious Teams content from <\/strong><em><strong>MessageEvents<\/strong><\/em><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"16\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nMessageEvents | where Timestamp &gt; ago(1d) | where ThreatTypes has \"Phish\" \u202f \u202f or ThreatTypes has \"Malware\" \u202f \u202f or ThreatTypes has \"Spam\" | project Timestamp, SenderDisplayName, SenderEmailAddress, RecipientDetails, IsOwnedThread, ThreadType, IsExternalThread, ReportId\n<\/pre>\n<\/div>\n<p class=\"wp-block-paragraph\"><strong>Detect communication with external help desk\/support representatives<\/strong><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"15\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nMessageEvents | where Timestamp &gt; ago(5d) | where IsExternalThread == true | where (RecipientDetails contains \"help\" and RecipientDetails contains \"desk\") or (RecipientDetails contains \"it\" and RecipientDetails contains \"support\") or (RecipientDetails contains \"working\" and RecipientDetails contains \"home\") or (SenderDisplayName contains \"help\" and SenderDisplayName contains \"desk\") or (SenderDisplayName contains \"it\" and SenderDisplayName contains \"support\") or (SenderDisplayName contains \"working\" and SenderDisplayName contains \"home\") | project Timestamp, SenderDisplayName, SenderEmailAddress, RecipientDetails, IsOwnedThread, ThreadType\n<\/pre>\n<\/div>\n<p class=\"wp-block-paragraph\"><strong>Expand detection of communication with external help desk\/support representatives by searching for linked process executions<\/strong><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"11\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nlet portableExecutable = pack_array(\"binary.exe\", \"portable.exe\"); let timeAgo = ago(30d);\nMessageEvents | where Timestamp &gt; timeAgo | where IsExternalThread == true | where (RecipientDetails contains \"help\" and RecipientDetails contains \"desk\") or (RecipientDetails contains \"it\" and RecipientDetails contains \"support\") or (RecipientDetails contains \"working\" and RecipientDetails contains \"home\") | summarize spamEvent = min(Timestamp) by SenderEmailAddress | join kind=inner ( DeviceProcessEvents | where Timestamp &gt; timeAgo | where FileName in (portableExecutable) ) on $left.SenderEmailAddress == $right.InitiatingProcessAccountUpn | where spamEvent Timestamp\n<\/pre>\n<\/div>\n<p class=\"wp-block-paragraph\"><strong>Surface Teams threat activity using Microsoft Security Copilot<\/strong><\/p>\n<p class=\"wp-block-paragraph\"><a href=\"https:\/\/learn.microsoft.com\/en-us\/defender-xdr\/security-copilot-in-microsoft-365-defender\">Microsoft Security Copilot in Microsoft Defender<\/a>&nbsp;comes with a query assistant capability in advanced hunting. You can also run the following prompt in Microsoft Security Copilot pane in the Advanced hunting page or by reopening Copilot from the top of the query editor:<\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"11\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nShow me recent activity in the last 7 days that matches attack techniques described in the Microsoft Teams technique profile. Include relevant alerts, affected users and devices, and generate advanced hunting queries to investigate further.\n<\/pre>\n<\/div>\n<h3 class=\"wp-block-heading\" id=\"microsoft-sentinel\">Microsoft Sentinel<\/h3>\n<p class=\"wp-block-paragraph\"><strong>Possible Teams phishing activity<\/strong><\/p>\n<p class=\"wp-block-paragraph\">This query specifically monitors Microsoft Teams for one-on-one chats involving impersonated users (e.g., &#8216;Help Desk&#8217;, &#8216;Microsoft Security&#8217;).<\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"15\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nlet suspiciousUpns = DeviceProcessEvents | where DeviceId == \"alertedMachine\" | where isnotempty(InitiatingProcessAccountUpn) | project InitiatingProcessAccountUpn; CloudAppEvents | where Application == \"Microsoft Teams\" | where ActionType == \"ChatCreated\" | where isempty(AccountObjectId) | where RawEventData.ParticipantInfo.HasForeignTenantUsers == true | where RawEventData.CommunicationType == \"OneonOne\" | where RawEventData.ParticipantInfo.HasGuestUsers == false | where RawEventData.ParticipantInfo.HasOtherGuestUsers == false | where RawEventData.Members[0].DisplayName in (\"Microsoft Security\", \"Help Desk\", \"Help Desk Team\", \"Help Desk IT\", \"Microsoft Security\", \"office\") | where AccountId has \"@\" | extend TargetUPN = tolower(tostring(RawEventData.Members[1].UPN)) | where TargetUPN in (suspiciousUpns)\n<\/pre>\n<\/div>\n<p class=\"wp-block-paragraph\"><strong>Files uploaded to Teams and access summary<\/strong><\/p>\n<p class=\"wp-block-paragraph\">This query identifies files uploaded to Microsoft Teams chat files and their access history, specifically mentioning operations from SharePoint. It allows tracking of potential file collection activity through Teams-related storage.<\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"25\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nOfficeActivity | where RecordType =~ \"SharePointFileOperation\" | where Operation =~ \"FileUploaded\" | where UserId != \"app@sharepoint\" | where SourceRelativeUrl has \"Microsoft Teams Chat Files\" | join kind= leftouter ( OfficeActivity | where RecordType =~ \"SharePointFileOperation\" | where Operation =~ \"FileDownloaded\" or Operation =~ \"FileAccessed\" | where UserId != \"app@sharepoint\" | where SourceRelativeUrl has \"Microsoft Teams Chat Files\" ) on OfficeObjectId | extend userBag = bag_pack(UserId1, ClientIP1) | summarize make_set(UserId1, 10000), make_bag(userBag, 10000) by TimeGenerated, UserId, OfficeObjectId, SourceFileName | extend NumberUsers = array_length(bag_keys(bag_userBag)) | project timestamp=TimeGenerated, UserId, FileLocation=OfficeObjectId, FileName=SourceFileName, AccessedBy=bag_userBag, NumberOfUsersAccessed=NumberUsers | extend AccountName = tostring(split(UserId, \"@\")[0]), AccountUPNSuffix = tostring(split(UserId, \"@\")[1]) | extend Account_0_Name = AccountName | extend Account_0_UPNSuffix = AccountUPNSuffix\n<\/pre>\n<\/div>\n<h2 class=\"wp-block-heading\" id=\"references\">References<\/h2>\n<h2 class=\"wp-block-heading\" id=\"learn-more\">Learn more<\/h2>\n<p class=\"wp-block-paragraph\">For the latest security research from the Microsoft Threat Intelligence community, check out ff<\/p>\n<p class=\"wp-block-paragraph\">To get notified about new publications and to join discussions on social media, follow us on <a href=\"https:\/\/www.linkedin.com\/showcase\/microsoft-threat-intelligence\">LinkedIn<\/a>, <a href=\"https:\/\/x.com\/MsftSecIntel\">X (formerly Twitter)<\/a>, and <a href=\"https:\/\/bsky.app\/profile\/threatintel.microsoft.com\">Bluesky<\/a>.<\/p>\n<p class=\"wp-block-paragraph\">To hear stories and insights from the Microsoft Threat Intelligence community about the ever-evolving threat landscape, listen to the <a href=\"https:\/\/thecyberwire.com\/podcasts\/microsoft-threat-intelligence\">Microsoft Threat Intelligence podcast<\/a>.<\/p>\n<p>READ MORE <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2025\/10\/07\/disrupting-threats-targeting-microsoft-teams\/\">HERE<\/a><\/p>\n","protected":false},"excerpt":{"rendered":"<p>Threat actors seek to abuse Microsoft Teams features and capabilities across the attack chain, underscoring the importance for defenders to proactively monitor, detect, and respond effectively. In this blog, we recommend countermeasures and optimal controls across identity, endpoints, data apps, and network layers to help strengthen protection for enterprise Teams users.<br \/>\nThe post Disrupting threats targeting Microsoft Teams appeared first on Microsoft Security Blog. READ MORE HERE&#8230;<\/p>\n","protected":false},"author":2,"featured_media":0,"comment_status":"closed","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"colormag_page_layout":"default_layout","footnotes":""},"categories":[276],"tags":[],"class_list":["post-59474","post","type-post","status-publish","format-standard","hentry","category-microsoft-secure"],"yoast_head":"<!-- This site is optimized with the Yoast SEO plugin v27.8 - https:\/\/yoast.com\/product\/yoast-seo-wordpress\/ -->\n<title>Disrupting threats targeting Microsoft Teams 2026 | ThreatsHub Cybersecurity News<\/title>\n<meta name=\"description\" content=\"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security &amp; Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.\" \/>\n<meta name=\"robots\" content=\"index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1\" \/>\n<link rel=\"canonical\" href=\"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/\" \/>\n<meta property=\"og:locale\" content=\"en_US\" \/>\n<meta property=\"og:type\" content=\"article\" \/>\n<meta property=\"og:title\" content=\"Disrupting threats targeting Microsoft Teams 2026 | ThreatsHub Cybersecurity News\" \/>\n<meta property=\"og:description\" content=\"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security &amp; Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.\" \/>\n<meta property=\"og:url\" content=\"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/\" \/>\n<meta property=\"og:site_name\" content=\"ThreatsHub Cybersecurity News\" \/>\n<meta property=\"article:published_time\" content=\"2025-10-07T17:00:00+00:00\" \/>\n<meta property=\"og:image\" content=\"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/05\/Threatshub_Favicon1.jpg\" \/>\n\t<meta property=\"og:image:width\" content=\"432\" \/>\n\t<meta property=\"og:image:height\" content=\"435\" \/>\n\t<meta property=\"og:image:type\" content=\"image\/jpeg\" \/>\n<meta name=\"author\" content=\"TH Author\" \/>\n<meta name=\"twitter:card\" content=\"summary_large_image\" \/>\n<meta name=\"twitter:creator\" content=\"@threatshub\" \/>\n<meta name=\"twitter:site\" content=\"@threatshub\" \/>\n<meta name=\"twitter:label1\" content=\"Written by\" \/>\n\t<meta name=\"twitter:data1\" content=\"TH Author\" \/>\n\t<meta name=\"twitter:label2\" content=\"Est. reading time\" \/>\n\t<meta name=\"twitter:data2\" content=\"23 minutes\" \/>\n<script type=\"application\/ld+json\" class=\"yoast-schema-graph\">{\"@context\":\"https:\\\/\\\/schema.org\",\"@graph\":[{\"@type\":\"Article\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/disrupting-threats-targeting-microsoft-teams\\\/#article\",\"isPartOf\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/disrupting-threats-targeting-microsoft-teams\\\/\"},\"author\":{\"name\":\"TH Author\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#\\\/schema\\\/person\\\/12e0a8671ff89a863584f193e7062476\"},\"headline\":\"Disrupting threats targeting Microsoft Teams\",\"datePublished\":\"2025-10-07T17:00:00+00:00\",\"mainEntityOfPage\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/disrupting-threats-targeting-microsoft-teams\\\/\"},\"wordCount\":4172,\"publisher\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#organization\"},\"image\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/disrupting-threats-targeting-microsoft-teams\\\/#primaryimage\"},\"thumbnailUrl\":\"https:\\\/\\\/www.microsoft.com\\\/en-us\\\/security\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/10\\\/Teams-threats-attack-chain.webp\",\"articleSection\":[\"Microsoft Secure\"],\"inLanguage\":\"en-US\"},{\"@type\":\"WebPage\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/disrupting-threats-targeting-microsoft-teams\\\/\",\"url\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/disrupting-threats-targeting-microsoft-teams\\\/\",\"name\":\"Disrupting threats targeting Microsoft Teams 2026 | ThreatsHub Cybersecurity News\",\"isPartOf\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#website\"},\"primaryImageOfPage\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/disrupting-threats-targeting-microsoft-teams\\\/#primaryimage\"},\"image\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/disrupting-threats-targeting-microsoft-teams\\\/#primaryimage\"},\"thumbnailUrl\":\"https:\\\/\\\/www.microsoft.com\\\/en-us\\\/security\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/10\\\/Teams-threats-attack-chain.webp\",\"datePublished\":\"2025-10-07T17:00:00+00:00\",\"description\":\"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security & Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.\",\"breadcrumb\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/disrupting-threats-targeting-microsoft-teams\\\/#breadcrumb\"},\"inLanguage\":\"en-US\",\"potentialAction\":[{\"@type\":\"ReadAction\",\"target\":[\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/disrupting-threats-targeting-microsoft-teams\\\/\"]}]},{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/disrupting-threats-targeting-microsoft-teams\\\/#primaryimage\",\"url\":\"https:\\\/\\\/www.microsoft.com\\\/en-us\\\/security\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/10\\\/Teams-threats-attack-chain.webp\",\"contentUrl\":\"https:\\\/\\\/www.microsoft.com\\\/en-us\\\/security\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/10\\\/Teams-threats-attack-chain.webp\"},{\"@type\":\"BreadcrumbList\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/disrupting-threats-targeting-microsoft-teams\\\/#breadcrumb\",\"itemListElement\":[{\"@type\":\"ListItem\",\"position\":1,\"name\":\"Home\",\"item\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/\"},{\"@type\":\"ListItem\",\"position\":2,\"name\":\"Disrupting threats targeting Microsoft Teams\"}]},{\"@type\":\"WebSite\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#website\",\"url\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/\",\"name\":\"ThreatsHub Cybersecurity News\",\"description\":\"%%focuskw%% Threat Intel \u2013 Threat Intel Services \u2013 CyberIntelligence \u2013 Cyber Threat Intelligence - Threat Intelligence Feeds - Threat Intelligence Reports - CyberSecurity Report \u2013 Cyber Security PDF \u2013 Cybersecurity Trends - Cloud Sandbox \u2013- Threat IntelligencePortal \u2013 Incident Response \u2013 Threat Hunting \u2013 IOC - Yara - Security Operations Center \u2013 SecurityOperation Center \u2013 Security SOC \u2013 SOC Services - Advanced Threat - Threat Detection - TargetedAttack \u2013 APT \u2013 Anti-APT \u2013 Advanced Protection \u2013 Cyber Security Services \u2013 Cybersecurity Services -Threat Intelligence Platform\",\"publisher\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#organization\"},\"alternateName\":\"Threatshub.org\",\"potentialAction\":[{\"@type\":\"SearchAction\",\"target\":{\"@type\":\"EntryPoint\",\"urlTemplate\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/?s={search_term_string}\"},\"query-input\":{\"@type\":\"PropertyValueSpecification\",\"valueRequired\":true,\"valueName\":\"search_term_string\"}}],\"inLanguage\":\"en-US\"},{\"@type\":\"Organization\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#organization\",\"name\":\"ThreatsHub.org\",\"alternateName\":\"Threatshub.org\",\"url\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/\",\"logo\":{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#\\\/schema\\\/logo\\\/image\\\/\",\"url\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/05\\\/Threatshub_Favicon1.jpg\",\"contentUrl\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/05\\\/Threatshub_Favicon1.jpg\",\"width\":432,\"height\":435,\"caption\":\"ThreatsHub.org\"},\"image\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#\\\/schema\\\/logo\\\/image\\\/\"},\"sameAs\":[\"https:\\\/\\\/x.com\\\/threatshub\"]},{\"@type\":\"Person\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#\\\/schema\\\/person\\\/12e0a8671ff89a863584f193e7062476\",\"name\":\"TH Author\",\"image\":{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\\\/\\\/secure.gravatar.com\\\/avatar\\\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g\",\"url\":\"https:\\\/\\\/secure.gravatar.com\\\/avatar\\\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g\",\"contentUrl\":\"https:\\\/\\\/secure.gravatar.com\\\/avatar\\\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g\",\"caption\":\"TH Author\"}}]}<\/script>\n<!-- \/ Yoast SEO plugin. -->","yoast_head_json":{"title":"Disrupting threats targeting Microsoft Teams 2026 | ThreatsHub Cybersecurity News","description":"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security & Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.","robots":{"index":"index","follow":"follow","max-snippet":"max-snippet:-1","max-image-preview":"max-image-preview:large","max-video-preview":"max-video-preview:-1"},"canonical":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/","og_locale":"en_US","og_type":"article","og_title":"Disrupting threats targeting Microsoft Teams 2026 | ThreatsHub Cybersecurity News","og_description":"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security & Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.","og_url":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/","og_site_name":"ThreatsHub Cybersecurity News","article_published_time":"2025-10-07T17:00:00+00:00","og_image":[{"width":432,"height":435,"url":"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/05\/Threatshub_Favicon1.jpg","type":"image\/jpeg"}],"author":"TH Author","twitter_card":"summary_large_image","twitter_creator":"@threatshub","twitter_site":"@threatshub","twitter_misc":{"Written by":"TH Author","Est. reading time":"23 minutes"},"schema":{"@context":"https:\/\/schema.org","@graph":[{"@type":"Article","@id":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/#article","isPartOf":{"@id":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/"},"author":{"name":"TH Author","@id":"https:\/\/www.threatshub.org\/blog\/#\/schema\/person\/12e0a8671ff89a863584f193e7062476"},"headline":"Disrupting threats targeting Microsoft Teams","datePublished":"2025-10-07T17:00:00+00:00","mainEntityOfPage":{"@id":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/"},"wordCount":4172,"publisher":{"@id":"https:\/\/www.threatshub.org\/blog\/#organization"},"image":{"@id":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/#primaryimage"},"thumbnailUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/10\/Teams-threats-attack-chain.webp","articleSection":["Microsoft Secure"],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/","url":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/","name":"Disrupting threats targeting Microsoft Teams 2026 | ThreatsHub Cybersecurity News","isPartOf":{"@id":"https:\/\/www.threatshub.org\/blog\/#website"},"primaryImageOfPage":{"@id":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/#primaryimage"},"image":{"@id":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/#primaryimage"},"thumbnailUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/10\/Teams-threats-attack-chain.webp","datePublished":"2025-10-07T17:00:00+00:00","description":"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security & Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.","breadcrumb":{"@id":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/#primaryimage","url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/10\/Teams-threats-attack-chain.webp","contentUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/10\/Teams-threats-attack-chain.webp"},{"@type":"BreadcrumbList","@id":"https:\/\/www.threatshub.org\/blog\/disrupting-threats-targeting-microsoft-teams\/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https:\/\/www.threatshub.org\/blog\/"},{"@type":"ListItem","position":2,"name":"Disrupting threats targeting Microsoft Teams"}]},{"@type":"WebSite","@id":"https:\/\/www.threatshub.org\/blog\/#website","url":"https:\/\/www.threatshub.org\/blog\/","name":"ThreatsHub Cybersecurity News","description":"%%focuskw%% Threat Intel \u2013 Threat Intel Services \u2013 CyberIntelligence \u2013 Cyber Threat Intelligence - Threat Intelligence Feeds - Threat Intelligence Reports - CyberSecurity Report \u2013 Cyber Security PDF \u2013 Cybersecurity Trends - Cloud Sandbox \u2013- Threat IntelligencePortal \u2013 Incident Response \u2013 Threat Hunting \u2013 IOC - Yara - Security Operations Center \u2013 SecurityOperation Center \u2013 Security SOC \u2013 SOC Services - Advanced Threat - Threat Detection - TargetedAttack \u2013 APT \u2013 Anti-APT \u2013 Advanced Protection \u2013 Cyber Security Services \u2013 Cybersecurity Services -Threat Intelligence Platform","publisher":{"@id":"https:\/\/www.threatshub.org\/blog\/#organization"},"alternateName":"Threatshub.org","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https:\/\/www.threatshub.org\/blog\/?s={search_term_string}"},"query-input":{"@type":"PropertyValueSpecification","valueRequired":true,"valueName":"search_term_string"}}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https:\/\/www.threatshub.org\/blog\/#organization","name":"ThreatsHub.org","alternateName":"Threatshub.org","url":"https:\/\/www.threatshub.org\/blog\/","logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/www.threatshub.org\/blog\/#\/schema\/logo\/image\/","url":"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/05\/Threatshub_Favicon1.jpg","contentUrl":"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/05\/Threatshub_Favicon1.jpg","width":432,"height":435,"caption":"ThreatsHub.org"},"image":{"@id":"https:\/\/www.threatshub.org\/blog\/#\/schema\/logo\/image\/"},"sameAs":["https:\/\/x.com\/threatshub"]},{"@type":"Person","@id":"https:\/\/www.threatshub.org\/blog\/#\/schema\/person\/12e0a8671ff89a863584f193e7062476","name":"TH Author","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/secure.gravatar.com\/avatar\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g","url":"https:\/\/secure.gravatar.com\/avatar\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g","contentUrl":"https:\/\/secure.gravatar.com\/avatar\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g","caption":"TH Author"}}]}},"_links":{"self":[{"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/posts\/59474","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/users\/2"}],"replies":[{"embeddable":true,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/comments?post=59474"}],"version-history":[{"count":0,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/posts\/59474\/revisions"}],"wp:attachment":[{"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/media?parent=59474"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/categories?post=59474"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/tags?post=59474"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}