{"id":59103,"date":"2025-07-31T16:00:00","date_gmt":"2025-07-31T16:00:00","guid":{"rendered":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/?p=141542"},"modified":"2025-07-31T16:00:00","modified_gmt":"2025-07-31T16:00:00","slug":"frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats","status":"publish","type":"post","link":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/","title":{"rendered":"Frozen in transit: Secret Blizzard\u2019s AiTM campaign against diplomats"},"content":{"rendered":"<p class=\"wp-block-paragraph\">Microsoft Threat Intelligence has uncovered a cyberespionage campaign by the Russian state actor we track as Secret Blizzard that has been targeting embassies located in Moscow using an adversary-in-the-middle (AiTM) position to deploy their custom ApolloShadow malware. ApolloShadow has the capability to install a trusted root certificate to trick devices into trusting malicious actor-controlled sites, enabling Secret Blizzard to maintain persistence on diplomatic devices, likely for intelligence collection. This campaign, which has been ongoing since at least 2024, poses a high risk to foreign embassies, diplomatic entities, and other sensitive organizations operating in Moscow, particularly to those entities who rely on local internet providers.<\/p>\n<p class=\"wp-block-paragraph\">While we previously assessed with low confidence that the actor conducts cyberespionage activities within Russian borders against foreign and domestic entities, this is the first time we can confirm that they have the capability to do so at the Internet Service Provider (ISP) level. This means that diplomatic personnel using local ISP or telecommunications services in Russia are highly likely targets of Secret Blizzard\u2019s AiTM position within those services. In our previous <a href=\"https:\/\/www.microsoft.com\/security\/blog\/2024\/12\/04\/frequent-freeloader-part-i-secret-blizzard-compromising-storm-0156-infrastructure-for-espionage\/\">blog<\/a>, we reported the actor likely leverages Russia\u2019s domestic intercept systems such as the <a href=\"https:\/\/www.welivesecurity.com\/2018\/01\/09\/turlas-backdoor-laced-flash-player-installer\/\" target=\"_blank\" rel=\"noreferrer noopener\">System for Operative Investigative Activities<\/a> (SORM), which we assess may be integral in facilitating the actor\u2019s current AiTM activity, judging from the large-scale nature of these operations.<\/p>\n<p class=\"wp-block-paragraph\">This blog provides guidance on how organizations can protect against Secret Blizzard\u2019s AiTM ApolloShadow campaign, including forcing or routing all traffic through an encrypted tunnel to a trusted network or using an alternative provider\u2014such as a satellite-based connection\u2014hosted within a country that does not control or influence the provider\u2019s infrastructure. The blog also provides additional information on network defense, such as recommendations, indicators of compromise (IOCs), and detection details.<\/p>\n<p class=\"wp-block-paragraph\">Secret Blizzard is <a href=\"https:\/\/www.cisa.gov\/news-events\/cybersecurity-advisories\/aa23-129a\" target=\"_blank\" rel=\"noreferrer noopener\">attributed<\/a> by the United States Cybersecurity and Infrastructure Agency (CISA) as Russian Federal Security Service (Center 16). Secret Blizzard further overlaps with threat actors <a href=\"https:\/\/learn.microsoft.com\/en-us\/unified-secops-platform\/microsoft-threat-actor-naming\">tracked by other security vendors<\/a> by names such as VENOMOUS BEAR, Uroburos, Snake, Blue Python, Turla, Wraith, ATG26, and Waterbug.<\/p>\n<p class=\"wp-block-paragraph\">As part of our continuous monitoring, analysis, and reporting of the threat landscape, we are sharing our observations on Secret Blizzard\u2019s latest activity to raise awareness of this actor\u2019s tradecraft and educate organizations on how to harden their attack surface against this and similar activity. Although this activity poses a high risk to entities within Russia, the defense measures included in this blog are broadly applicable and can help organizations in any region reduce their risk from similar threats. Microsoft is also tracking other groups using similar techniques, including those documented by ESET in a previous <a href=\"https:\/\/www.eset.com\/us\/about\/newsroom\/press-releases\/eset-research-discovers-moustachedbouncer\/\" target=\"_blank\" rel=\"noreferrer noopener\">publication<\/a>.<\/p>\n<h2 class=\"wp-block-heading\" id=\"aitm-and-apolloshadow-deployment\">AiTM and ApolloShadow deployment<\/h2>\n<p class=\"wp-block-paragraph\">In February 2025, Microsoft Threat Intelligence observed Secret Blizzard conducting a cyberespionage campaign against foreign embassies located in Moscow, Russia, using an AiTM position to deploy the ApolloShadow malware to maintain persistence and collect intelligence from diplomatic entities. An <a href=\"https:\/\/attack.mitre.org\/techniques\/T1557\/\" target=\"_blank\" rel=\"noreferrer noopener\">adversary-in-the-middle<\/a> technique is when an adversary positions themself between two or more networks to support follow-on activity. The Secret Blizzard AiTM position is likely facilitated by lawful intercept and notably includes the installation of root certificates under the guise of Kaspersky Anti-Virus (AV). We assess this allows for TLS\/SSL stripping from the Secret Blizzard AiTM position, rendering the majority of the target\u2019s browsing in clear text including the delivery of certain tokens and credentials. Secret Blizzard has exhibited similar techniques in past cyberespionage <a href=\"https:\/\/web-assets.esetstatic.com\/wls\/2018\/01\/ESET_Turla_Mosquito.pdf\" target=\"_blank\" rel=\"noreferrer noopener\">campaigns<\/a> to infect foreign ministries in Eastern Europe by tricking users to download a trojanized Flash installer from an AiTM position.<\/p>\n<h3 class=\"wp-block-heading\" id=\"initial-access\">Initial access&nbsp;&nbsp;&nbsp;&nbsp;<\/h3>\n<p class=\"wp-block-paragraph\">In this most recent campaign, the initial access mechanism used by Secret Blizzard is facilitated by an AiTM position at the ISP\/Telco level inside Russia, in which the actor redirects target devices by putting them behind a captive portal. Captive portals are legitimate web pages designed to manage network access, such as those encountered when connecting to the internet at a hotel or airport. Once behind a captive portal, the <a href=\"https:\/\/learn.microsoft.com\/troubleshoot\/windows-client\/networking\/internet-explorer-edge-open-connect-corporate-public-network\">Windows Test Connectivity Status Indicator<\/a> is initiated\u2014a legitimate service that determines whether a device has internet access by sending an HTTP GET request to <em>hxxp:\/\/www.msftconnecttest[.]<\/em><em>com\/redirect<\/em> which should direct to <em>msn[.]com<\/em>. &nbsp;<\/p>\n<h3 class=\"wp-block-heading\" id=\"delivery-and-installation\">Delivery and installation<\/h3>\n<p class=\"wp-block-paragraph\">Once the system opens the browser window to this address, the system is redirected to a separate actor-controlled domain that likely displays a certificate validation error which prompts the target to download and execute ApolloShadow. Following execution, ApolloShadow checks for the privilege level of the <em>ProcessToken<\/em> and if the device is not running on default administrative settings, then the malware displays the user access control (UAC) pop-up window to prompt the user to install certificates with the file name <em>CertificateDB.exe<\/em>, which masquerades as a Kaspersky installer to install root certificates and allow the actor to gain elevated privileges in the system.<\/p>\n<figure class=\"wp-block-image size-full\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/Figure-1.-Secret-Blizzard-AiTM-infection-chain-1.webp\" alt=\"The infect chain displays the back and forth between the unknowing target and Secret Blizzard, with the target first getting an unexpected response to a connection, leading the attacker to redirecting the target to their domain. The target downloads and executes the malware, which ultimately beacons the attacker's server at their attacker-controlled IP address to deliver a secondary payload. \" class=\"wp-image-141557 webp-format\" srcset data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/Figure-1.-Secret-Blizzard-AiTM-infection-chain-1.webp\"><figcaption class=\"wp-element-caption\"><em>Figure 1. Secret Blizzard AiTM infection chain<\/em><\/figcaption><\/figure>\n<h3 class=\"wp-block-heading\" id=\"apolloshadow-malware\">ApolloShadow malware<\/h3>\n<p class=\"wp-block-paragraph\">ApolloShadow uses two execution paths depending on the privilege level of the running process. The token of the running process is retrieved using the API <em>GetTokenInformationType<\/em> and the value of <em>TokenInformation<\/em> is checked to see if the token contains the <em>TokenElevationTypeFull<\/em>type<strong>. <\/strong>If it does not have that privilege level, ApolloShadow executes a low privilege execution path<strong>.<\/strong><\/p>\n<figure class=\"wp-block-image size-full\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/Figure-2.-ApolloShadow-execution-flow.webp\" alt=\"Diagram of the ApolloShadow execution flow starting with CertificateDB.exe checking token access, using a GET request to receive and execute the VB Script. At the same time, it installs the certificate to elevate privileges, ultimately installing root certificates. changing the connected networks to private, and adding an admin user.\" class=\"wp-image-141555 webp-format\" srcset data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/Figure-2.-ApolloShadow-execution-flow.webp\"><figcaption class=\"wp-element-caption\"><em>Figure 2. ApolloShadow execution flow<\/em><\/figcaption><\/figure>\n<h2 class=\"wp-block-heading\" id=\"low-privilege-execution\">Low privilege execution<\/h2>\n<p class=\"wp-block-paragraph\">When executing the low privilege path, the first action is to collect information about the host to send back to the AiTM controlled command and control (C2). First, the host\u2019s IP information is collected using the API <em>GetIpAddrTable<\/em>, which collects information from the <em>IpAddrTable<\/em>. Each entry is individually Base64-encoded and delineated by a pipe character with <em>\\r\\n<\/em> appended, then combined into one string. For example:<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">172.29.162[.]128 00-15-5D-04-04-1C<\/li>\n<li class=\"wp-block-list-item\">127.0.0[.]1<\/li>\n<\/ul>\n<p class=\"has-text-align-center wp-block-paragraph\"><code>&nbsp;\"|MTcyLjI5LjE2Mi4xMjggMDAtMTUtNUQtMDQtMDQtMUM=|\\r\\n|MTI3LjAuMC4xIA==|\\r\\n\"<\/code><\/p>\n<p class=\"wp-block-paragraph\">&nbsp;Then the entire string is Base64-encoded once again in preparation for exfiltration to the C2 host:<\/p>\n<p class=\"has-text-align-center wp-block-paragraph\"><code>\"fE1UY3lMakk1TGpFMk1pNHhNamdnTURBdE1UVXROVVF0TURRdE1EUXRNVU09fA0KfE1USTNMakF1TUM0eElBPT18DQo=\"<\/code><\/p>\n<p class=\"wp-block-paragraph\">The encoded network information is added as a query string to a GET request with the destination URL <em>hxxp<\/em><em>:\/\/timestamp.digicert[.]com\/registered<\/em>. Two query parameters are included with the request, <em>code<\/em> and <em>t<\/em>.&nbsp; The <em>Code<\/em> parameters contains a hardcoded set of characters and the <em>t<\/em> variable has the encoded IP address information, as shown below:<\/p>\n<p class=\"has-text-align-center wp-block-paragraph\"><code>code=DQBBBBBBBBBOBBBBBBBBBBgBBBBBBBBBny_t???????t=fE1UY3lMakk1TGpFMk1pNHhNamdnTURBdE1UVXROVVF0TURRdE1EUXRNVU09fA0KfE1USTNMakF1TUM0eElBPT18DQo=<\/code><\/p>\n<p class=\"wp-block-paragraph\">While the timestamp subdomain does exist for Digicert, the \/<em>registered<\/em> resource does not. Due to the AiTM position of the actor, Secret Blizzard can use DNS manipulation to redirect legitimate-looking communication to the actor-controlled C2 and return an encoded VBScript as the second-stage payload.&nbsp;<\/p>\n<p class=\"wp-block-paragraph\">When the response comes back from the redirected Digicert request, the file name that is used to write the script to disk is decoded for use. ApolloShadow uses string obfuscation in several places throughout the binary to hide critical strings. These strings are blocks of encoded characters that are encoded using XOR with a separate set of hardcoded constants. While this is not a particularly sophisticated technique, it is enough to obscure the strings from view at first glance. The strings are decoded as they are used and then re-encoded after use to remove traces of the strings from memory.&nbsp;<\/p>\n<figure class=\"wp-block-image size-full is-resized\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/image-16.webp\" alt=\"Screenshot of code depicting the string decoding operation for the VB script name\" class=\"wp-image-141544 webp-format\" srcset data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/image-16.webp\"><figcaption class=\"wp-element-caption\"><em>Figure 2. String decoding operation for VB script name<\/em><\/figcaption><\/figure>\n<p class=\"wp-block-paragraph\">The decoded file name is <em>edgB4ACD.vbs<\/em> and the file name string is concatenated by the malware with the results of querying the environment variable for the <em>TEMP<\/em> directory to create the path for the target script. We were unable to recover the script, but the header of the response is checked for the first 12 characters to see if it matches the string <em>MDERPWSAB64B<\/em>. Once ApolloShadow has properly decoded the script, it executes the script using the Windows API call <em>CreateProcessW<\/em> with the command line to launch <em>wscript<\/em> and the path to <em>edgB4ACD.vbs<\/em>.<\/p>\n<p class=\"wp-block-paragraph\">Finally, the ApolloShadow process launches itself again using <em>ShellExecuteA,<\/em> which presents the user with an UAC window to bypass UAC mechanisms and prompt the user to grant the malware the highest privileges available to the user.<\/p>\n<figure class=\"wp-block-image size-full\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/image-20.webp\" alt=\"Screenshot of the UAC popup which asks the user if they want to allow this app from an unknown publisher to make changes to their device. The file is called CertificateDB.exe and the user can click Yes or No.\" class=\"wp-image-141554 webp-format\" srcset data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/image-20.webp\"><figcaption class=\"wp-element-caption\">&nbsp;<em>Figure 3. UAC popup to request elevated privileges from the user<\/em><\/figcaption><\/figure>\n<h2 class=\"wp-block-heading\" id=\"elevated-privilege-execution\">Elevated privilege execution<\/h2>\n<p class=\"wp-block-paragraph\">When the process is executed with sufficient elevated privileges, ApolloShadow alters the host by setting all networks to <em>Private<\/em>. This induces several changes including allowing the host device to become discoverable, and relaxing firewall rules to enable file sharing. While we did not see any direct attempts for lateral movement, the main reason for these modifications is likely to reduce the difficulty of lateral movement on the network. ApolloShadow uses two different methods to perform this change.<\/p>\n<p class=\"wp-block-paragraph\">The first method is through the registry settings for <em>NetworkProfiles: SOFTWARE\\\\Microsoft\\\\Windows NT\\\\CurrentVersion\\\\NetworkList\\\\Profiles<\/em>. The network\u2019s globally unique identifiers (GUIDs) are parsed for each connected network, and the malware modifies the value <em>Category<\/em> by setting it to 0. This change sets the profile of the network to <em>Private<\/em> after the host has been rebooted.<\/p>\n<figure class=\"wp-block-image size-full\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/image-19.webp\" alt=\"Screenshot of the registry settings for network profiles\" class=\"wp-image-141553 webp-format\" srcset data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/image-19.webp\"><figcaption class=\"wp-element-caption\"><em>Figure 4. Registry settings for network profiles<\/em><\/figcaption><\/figure>\n<p class=\"wp-block-paragraph\">The second method directly sets firewall rules using Component Object Model (COM) objects that enable file sharing and turn on network discovery. Several strings are decoded using the same method as above and concatenated to create the firewall rules they want to modify.<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\"><code>FirewallAPI.dll,-32752<\/code>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">This command enables the <strong>Network Discovery<\/strong> rule group<\/li>\n<\/ul>\n<\/li>\n<li class=\"wp-block-list-item\"><code>FirewallAPI.dll,-28502<\/code>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">This command enables all rules in the <strong>File and Printer Sharing<\/strong> group<\/li>\n<\/ul>\n<\/li>\n<\/ul>\n<p class=\"wp-block-paragraph\">The strings are passed to the COM objects to enable the rules if they are not already enabled.<\/p>\n<figure class=\"wp-block-image size-full is-resized\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/image-15.webp\" alt=\"Screenshot of code depicting COM objects that were used to modify firewall rules\" class=\"wp-image-141548 webp-format\" srcset data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/image-15.webp\"><figcaption class=\"wp-element-caption\"><em>Figure 5. COM objects used to modify firewall rules<\/em><\/figcaption><\/figure>\n<p class=\"wp-block-paragraph\">Both techniques have some crossover, but the following table provides a comparison overview of each method.<\/p>\n<figure class=\"wp-block-table\">\n<table class=\"has-fixed-layout\">\n<tbody readability=\"3\">\n<tr>\n<td><strong>Technique<\/strong><\/td>\n<td><strong>Purpose<\/strong><\/td>\n<td><strong>Timing<\/strong><\/td>\n<td><strong>Stealth<\/strong><\/td>\n<td><strong>Effect<\/strong><\/td>\n<\/tr>\n<tr readability=\"2\">\n<td>Registry profile change<\/td>\n<td>Sets network to <em>Private<\/em><\/td>\n<td>Requires reboot<\/td>\n<td>High<\/td>\n<td>Broadly relaxes firewall posture<\/td>\n<\/tr>\n<tr readability=\"4\">\n<td>COM-based rule enablement<\/td>\n<td>Activates specific rules<\/td>\n<td>Immediate<\/td>\n<td>Moderate<\/td>\n<td>Opens precise ports for discovery and sharing<\/td>\n<\/tr>\n<\/tbody>\n<\/table>\n<\/figure>\n<p class=\"wp-block-paragraph\">From here, ApolloShadow presents the user with a window showing that the certificates are being installed.&nbsp;&nbsp;<\/p>\n<figure class=\"wp-block-image size-full\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/image-18.webp\" alt=\"A screenshot of the window displayed to the user which shows a loading bar called K Certificate Installation\" class=\"wp-image-141552 webp-format\" srcset data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/image-18.webp\"><figcaption class=\"wp-element-caption\"><em>Figure 6. Window displayed to the user during execution<\/em><\/figcaption><\/figure>\n<p class=\"wp-block-paragraph\">A new thread performs the remainder of the functionality. The two root certificates being installed are written to the <em>%TEMP%<\/em> directory with a temporary name and the extension <em>crt<\/em>. The certificate installation is performed by using the Windows certutil utility and the temporary files are deleted following the execution of the commands.<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\"><code>certutil.exe -f -Enterprise -addstore root \"C:\\Users\\&lt;username&gt;\\AppData\\Local\\Temp\\crt3C5C.tmp\"<\/code><\/li>\n<li class=\"wp-block-list-item\"><code>&nbsp;certutil.exe -f -Enterprise -addstore ca \"C:\\Users\\&lt;username&gt;\\AppData\\Local\\Temp\\crt53FF.tmp\"<\/code><\/li>\n<\/ul>\n<p class=\"wp-block-paragraph\">The malware must add a preference file to the Firefox preference directory because Firefox uses different certificate stores than browsers such as Chromium, which results in Firefox not trusting the root and enterprise store by default. ApolloShadow reads the registry key that points to the installation of the application and builds a path to the preference directory from there. A file is written to disk called <em>wincert.js<\/em> containing a preference modification for Firefox browsers, allowing Firefox to trust the root certificates added to the operating system\u2019s certificate store.&nbsp;<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\"><code>pref(\"security.enterprise_roots.enabled\", true);\" privilege<\/code><\/li>\n<\/ul>\n<p class=\"wp-block-paragraph\">The final step is to create an administrative user with the username <em>UpdatusUser<\/em> and a hardcoded password on the infected system using the Windows API <em>NetUserAdd<\/em>. The password is also set to never expire.<\/p>\n<figure class=\"wp-block-image size-full\"><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/image-17.webp\" alt=\"Screenshot of an admin user being added to an infected system with the username UpdatusUser\" class=\"wp-image-141551 webp-format\" srcset data-orig-src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/image-17.webp\"><figcaption class=\"wp-element-caption\"><em>Figure 7. Administrator user added to infected system<\/em><\/figcaption><\/figure>\n<p class=\"wp-block-paragraph\">ApolloShadow has successfully installed itself on the infected host and has persistent access using the new local administrator user.<\/p>\n<h2 class=\"wp-block-heading\" id=\"defending-against-secret-blizzard-activity\">Defending against Secret Blizzard activity<\/h2>\n<p class=\"wp-block-paragraph\">Microsoft recommends that all customers, but especially sensitive organizations operating in Moscow, should implement the following recommendations to mitigate against Secret Blizzard activity.<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Route all traffic through an encrypted tunnel to a trusted network or use a virtual private network (VPN) service provider, such as a satellite-based provider, whose infrastructure is not controlled or influenced by outside parties.<\/li>\n<\/ul>\n<p class=\"wp-block-paragraph\">Microsoft also recommends the following guidance to enhance protection and mitigate potential threats:<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Practice the&nbsp;<a href=\"https:\/\/learn.microsoft.com\/windows-server\/identity\/ad-ds\/plan\/security-best-practices\/implementing-least-privilege-administrative-models\">principle of least privilege<\/a>, use multifactor authentication (MFA), and audit privileged account activity in your environments to slow and stop attackers. Avoid the use of domain-wide, admin-level service accounts and restrict local administrative privileges. These mitigation steps reduce the paths that attackers have available to them to accomplish their goals and lower the risk of the compromise spreading in your environment.<\/li>\n<li class=\"wp-block-list-item\">Regularly review highly privileged groups like Administrators, Remote Desktop Users, and Enterprise Admins. Threat actors may add accounts to these groups to maintain persistence and disguise their activity.<\/li>\n<li class=\"wp-block-list-item\">Turn on&nbsp;<a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/configure-block-at-first-sight-microsoft-defender-antivirus\">cloud-delivered protection<\/a>&nbsp;in Microsoft Defender Antivirus or the equivalent for your antivirus product to cover rapidly evolving attacker tools and techniques.<\/li>\n<li class=\"wp-block-list-item\">Run&nbsp;<a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/edr-in-block-mode?ocid=magicti%3Cem%3Eta%3C\/em%3Elearndoc\">endpoint detection and response (EDR) in block mode<\/a>, so that Defender for Endpoint can block malicious artifacts, even when your non-Microsoft antivirus doesn\u2019t detect the threat or when Microsoft Defender Antivirus is running in passive mode. EDR in block mode works behind the scenes to remediate malicious artifacts detected post-breach.&nbsp;<\/li>\n<li class=\"wp-block-list-item\">Turn on&nbsp;<a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/attack-surface-reduction-rules-reference?ocid=magicti_ta_learndoc\">attack surface reduction rules<\/a>&nbsp;to prevent common attack techniques. These rules, which can be configured by all Microsoft Defender Antivirus customers and not just those using the EDR solution, offer significant hardening against common attack vectors.<\/li>\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/attack-surface-reduction-rules-reference#block-executable-files-from-running-unless-they-meet-a-prevalence-age-or-trusted-list-criterion\">Block executable files from running unless they meet a prevalence, age, or trusted list criterion<\/a><\/li>\n<li class=\"wp-block-list-item\"><a href=\"https:\/\/learn.microsoft.com\/defender-endpoint\/attack-surface-reduction-rules-reference#block-execution-of-potentially-obfuscated-scripts\">Block execution of potentially obfuscated scripts<\/a><\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\" id=\"microsoft-defender-xdr-detections\">Microsoft Defender XDR detections<\/h2>\n<p class=\"wp-block-paragraph\">Microsoft Defender XDR customers can refer to the list of applicable detections below. Microsoft Defender XDR coordinates detection, prevention, investigation, and response across endpoints, identities, email, apps to provide integrated protection against attacks like the threat discussed in this blog.<\/p>\n<p class=\"wp-block-paragraph\">Customers with provisioned access can also use <a href=\"https:\/\/learn.microsoft.com\/defender-xdr\/security-copilot-in-microsoft-365-defender\">Microsoft Security Copilot in Microsoft Defender<\/a> to investigate and respond to incidents, hunt for threats, and protect their organization with relevant threat intelligence.<\/p>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-antivirus\">Microsoft Defender Antivirus<\/h3>\n<p class=\"wp-block-paragraph\">Microsoft Defender Antivirus detects this threat as the following malware:<\/p>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-for-endpoint\">Microsoft Defender for Endpoint<\/h3>\n<p class=\"wp-block-paragraph\">The following alerts might indicate threat activity related to this threat. Note, however, that these alerts can be also triggered by unrelated threat activity.<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Secret Blizzard Actor activity detected<\/li>\n<li class=\"wp-block-list-item\">Suspicious root certificate installation<\/li>\n<li class=\"wp-block-list-item\">Suspicious certutil activity<\/li>\n<li class=\"wp-block-list-item\">User account created under suspicious circumstances<\/li>\n<li class=\"wp-block-list-item\">A script with suspicious content was observed<\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\" id=\"microsoft-security-copilot\">Microsoft Security Copilot<\/h2>\n<p class=\"wp-block-paragraph\">Security Copilot customers can use the standalone experience to <a href=\"https:\/\/learn.microsoft.com\/copilot\/security\/prompting-security-copilot#create-your-own-prompts\">create their own prompts<\/a> or run the following <a href=\"https:\/\/learn.microsoft.com\/copilot\/security\/using-promptbooks\">pre-built promptbooks<\/a> to automate incident response or investigation tasks related to this threat:<\/p>\n<ul class=\"wp-block-list\">\n<li class=\"wp-block-list-item\">Incident investigation<\/li>\n<li class=\"wp-block-list-item\">Microsoft User analysis<\/li>\n<li class=\"wp-block-list-item\">Threat actor profile<\/li>\n<li class=\"wp-block-list-item\">Threat Intelligence 360 report based on MDTI article<\/li>\n<li class=\"wp-block-list-item\">Vulnerability impact assessment<\/li>\n<\/ul>\n<p class=\"wp-block-paragraph\">Note that some promptbooks require access to plugins for Microsoft products such as Microsoft Defender XDR or Microsoft Sentinel.<\/p>\n<h2 class=\"wp-block-heading\" id=\"threat-intelligence-reports\">Threat intelligence reports<\/h2>\n<p class=\"wp-block-paragraph\">Microsoft customers can use the following reports in Microsoft products to get the most up-to-date information about the threat actor, malicious activity, and techniques discussed in this blog. These reports provide the intelligence, protection information, and recommended actions to prevent, mitigate, or respond to associated threats found in customer environments.<\/p>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-threat-intelligence\">Microsoft Defender Threat Intelligence<\/h3>\n<p class=\"wp-block-paragraph\">Microsoft Security Copilot customers can also use the <a href=\"https:\/\/learn.microsoft.com\/defender\/threat-intelligence\/security-copilot-and-defender-threat-intelligence?bc=%2Fsecurity-copilot%2Fbreadcrumb%2Ftoc.json&amp;toc=%2Fsecurity-copilot%2Ftoc.json#turn-on-the-security-copilot-integration-in-defender-ti\">Microsoft Security Copilot integration<\/a> in Microsoft Defender Threat Intelligence, either in the Security Copilot standalone portal or in the <a href=\"https:\/\/learn.microsoft.com\/defender\/threat-intelligence\/using-copilot-threat-intelligence-defender-xdr\">embedded experience<\/a> in the Microsoft Defender portal to get more information about this threat actor.<\/p>\n<h2 class=\"wp-block-heading\" id=\"hunting-queries\">Hunting queries<\/h2>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-xdr\">Microsoft Defender XDR<\/h3>\n<p class=\"wp-block-paragraph\">Microsoft Defender XDR customers can run the following query to find related activity in their networks:<\/p>\n<p class=\"wp-block-paragraph\">Surface devices that attempt to download a file within two minutes after captive portal redirection. This activity may indicate a first stage AiTM attack\u2014such as the one utilized by Secret Blizzard\u2014against a device.<\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"20\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title>\nlet CaptiveRedirectEvents = DeviceNetworkEvents | where RemoteUrl contains \"msftconnecttest.com\/redirect\" | project DeviceId, RedirectTimestamp = Timestamp, RemoteUrl; let FileDownloadEvents = DeviceFileEvents | where ActionType == \"FileDownloaded\" | project DeviceId, DownloadTimestamp = Timestamp, FileName, FolderPath; CaptiveRedirectEvents | join kind=inner (FileDownloadEvents) on DeviceId | where DownloadTimestamp between (RedirectTimestamp .. (RedirectTimestamp + 2m)) | project DeviceId, RedirectTimestamp, RemoteUrl, DownloadTimestamp, FileName, FolderPath\n<\/pre>\n<\/div>\n<h3 class=\"wp-block-heading\" id=\"microsoft-sentinel-1\">Microsoft Sentinel<\/h3>\n<p class=\"wp-block-paragraph\">Microsoft Sentinel customers can use the TI Mapping analytics (a series of analytics all prefixed with \u2018TI map\u2019) to automatically match the malicious domain indicators mentioned in this blog post with data in their workspace. If the TI Map analytics are not currently deployed, customers can install the Threat Intelligence solution from the <a href=\"https:\/\/learn.microsoft.com\/azure\/sentinel\/sentinel-solutions-deploy\">Microsoft Sentinel Content Hub<\/a> to have the analytics rule deployed in their Sentinel workspace.<\/p>\n<p class=\"wp-block-paragraph\">Below are the queries using Sentinel Advanced Security Information Model (ASIM) functions to hunt threats across both Microsoft first party and third-party data sources. ASIM also supports deploying parsers to specific workspaces from GitHub, using an ARM template or manually.<\/p>\n<p class=\"wp-block-paragraph\"><strong>Detect network IP and domain indicators of compromise using ASIM<\/strong><\/p>\n<p class=\"wp-block-paragraph\">The below query checks IP addresses and domain indicators of compromise (IOCs) across data sources supported by ASIM Network session parser.<\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"18\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title>\n\/\/IP list and domain list- _Im_NetworkSession\nlet lookback = 30d;\nlet ioc_ip_addr = dynamic([\"45.61.149.109\"]);\nlet ioc_domains = dynamic([\"kav-certificates.info\"]);\n_Im_NetworkSession(starttime=todatetime(ago(lookback)), endtime=now())\n| where DstIpAddr in (ioc_ip_addr) or DstDomain has_any (ioc_domains)\n| summarize imNWS_mintime=min(TimeGenerated), imNWS_maxtime=max(TimeGenerated), EventCount=count() by SrcIpAddr, DstIpAddr, DstDomain, Dvc, EventProduct, EventVendor\n<\/pre>\n<\/div>\n<p class=\"wp-block-paragraph\"><strong>Detect network and files hashes indicators of compromise using ASIM<\/strong><\/p>\n<p class=\"wp-block-paragraph\">The below queries will check IP addresses and file hash IOCs across data sources supported by ASIM Web session parser.<\/p>\n<p class=\"wp-block-paragraph\">Detect network indicators of compromise and domains using ASIM<\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"18\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title>\n\/\/IP list - _Im_WebSession\nlet lookback = 30d;\nlet ioc_ip_addr = dynamic([\"45.61.149.109\"]);\nlet ioc_sha_hashes =dynamic([\"13fafb1ae2d5de024e68f2e2fc820bc79ef0690c40dbfd70246bcc394c52ea20\"]);\n_Im_WebSession(starttime=todatetime(ago(lookback)), endtime=now())\n| where DstIpAddr in (ioc_ip_addr) or FileSHA256 in (ioc_sha_hashes)\n| summarize imWS_mintime=min(TimeGenerated), imWS_maxtime=max(TimeGenerated), EventCount=count() by SrcIpAddr, DstIpAddr, Url, Dvc, EventProduct, EventVendor\n<\/pre>\n<\/div>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"8\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title>\n\/\/ Domain list - _Im_WebSession\nlet ioc_domains = dynamic([\"kav-certificates.info\"]);\n_Im_WebSession (url_has_any = ioc_domains)\n<\/pre>\n<\/div>\n<p class=\"wp-block-paragraph\"><strong>Detect files hashes indicators of compromise using ASIM<\/strong><\/p>\n<p class=\"wp-block-paragraph\">The below query will check IP addresses and file hash IOCs across data sources supported by ASIM FileEvent parser.<\/p>\n<p class=\"wp-block-paragraph\">Detect network and files hashes indicators of compromise using ASIM<\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"13\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title>\n\/\/ file hash list - imFileEvent\nlet ioc_sha_hashes =dynamic([\"13fafb1ae2d5de024e68f2e2fc820bc79ef0690c40dbfd70246bcc394c52ea20\"]);\nimFileEvent\n| where SrcFileSHA256 in (ioc_sha_hashes) or\nTargetFileSHA256 in (ioc_sha_hashes)\n| extend AccountName = tostring(split(User, @'')[1]), AccountNTDomain = tostring(split(User, @'')[0])\n| extend AlgorithmType = \"SHA256\"\n<\/pre>\n<\/div>\n<h3 class=\"wp-block-heading\" id=\"microsoft-sentinel\">Indicators of compromise<\/h3>\n<figure class=\"wp-block-table\">\n<table class=\"has-fixed-layout\">\n<tbody readability=\"4\">\n<tr>\n<td><strong>Indicator<\/strong><\/td>\n<td><strong>Type<\/strong><\/td>\n<td><strong>Description<\/strong><\/td>\n<\/tr>\n<tr readability=\"2\">\n<td><em>kav-certificates[.]info<\/em><\/td>\n<td>Domain<\/td>\n<td>Actor-controlled domain that downloads the malware<\/td>\n<\/tr>\n<tr readability=\"2\">\n<td>45.61.149[.]109<\/td>\n<td>IP address<\/td>\n<td>Actor-controlled IP address<\/td>\n<\/tr>\n<tr readability=\"2\">\n<td>13fafb1ae2d5de024e68f2e2fc820bc79ef0690c40dbfd70246bcc394c52ea20<\/td>\n<td>SHA256<\/td>\n<td>ApolloShadow malware<\/td>\n<\/tr>\n<tr readability=\"2\">\n<td><em>CertificateDB.exe<\/em><\/td>\n<td>File name<\/td>\n<td>File name associated with ApolloShadow sample<\/td>\n<\/tr>\n<\/tbody>\n<\/table>\n<\/figure>\n<h2 class=\"wp-block-heading\" id=\"references\">References<\/h2>\n<h2 class=\"wp-block-heading\" id=\"acknowledgments\">Acknowledgments<\/h2>\n<h2 class=\"wp-block-heading\" id=\"learn-more\">Learn more<\/h2>\n<p class=\"wp-block-paragraph\">Meet the experts behind Microsoft Threat Intelligence, Incident Response, and the Microsoft Security Response Center at our <a href=\"https:\/\/microsoftsecurityevents.eventbuilder.com\/events\/11f048838dabd650892acff3dd777035?ref=blog\" target=\"_blank\" rel=\"noreferrer noopener\">VIP Mixer at Black Hat 2025<\/a>. Discover how our end-to-end platform can help you strengthen resilience and elevate your security posture.<\/p>\n<p class=\"wp-block-paragraph\">For the latest security research from the Microsoft Threat Intelligence community, check out the <a href=\"https:\/\/aka.ms\/threatintelblog\">Microsoft Threat Intelligence Blog<\/a>.<\/p>\n<p class=\"wp-block-paragraph\">To get notified about new publications and to join discussions on social media, follow us on <a href=\"https:\/\/www.linkedin.com\/showcase\/microsoft-threat-intelligence\" target=\"_blank\" rel=\"noreferrer noopener\">LinkedIn<\/a>, <a href=\"https:\/\/x.com\/MsftSecIntel\" target=\"_blank\" rel=\"noreferrer noopener\">X (formerly Twitter)<\/a>, and <a href=\"https:\/\/bsky.app\/profile\/threatintel.microsoft.com\" target=\"_blank\" rel=\"noreferrer noopener\">Bluesky<\/a>.<\/p>\n<p class=\"wp-block-paragraph\">To hear stories and insights from the Microsoft Threat Intelligence community about the ever-evolving threat landscape, listen to the <a href=\"https:\/\/thecyberwire.com\/podcasts\/microsoft-threat-intelligence\" target=\"_blank\" rel=\"noreferrer noopener\">Microsoft Threat Intelligence podcast<\/a>. &nbsp;<\/p>\n<p>READ MORE <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2025\/07\/31\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/\">HERE<\/a><\/p>\n","protected":false},"excerpt":{"rendered":"<p>Microsoft Threat Intelligence has uncovered a cyberespionage campaign by the Russian state actor we track as Secret Blizzard that has been ongoing since at least 2024, targeting embassies in Moscow using an adversary-in-the-middle (AiTM) position to deploy their custom ApolloShadow malware.<br \/>\nThe post Frozen in transit: Secret Blizzard\u2019s AiTM campaign against diplomats appeared first on Microsoft Security Blog. READ MORE HERE&#8230;<\/p>\n","protected":false},"author":2,"featured_media":0,"comment_status":"closed","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"colormag_page_layout":"default_layout","footnotes":""},"categories":[276],"tags":[],"class_list":["post-59103","post","type-post","status-publish","format-standard","hentry","category-microsoft-secure"],"yoast_head":"<!-- This site is optimized with the Yoast SEO plugin v27.8 - https:\/\/yoast.com\/product\/yoast-seo-wordpress\/ -->\n<title>Frozen in transit: Secret Blizzard\u2019s AiTM campaign against diplomats 2026 | ThreatsHub Cybersecurity News<\/title>\n<meta name=\"description\" content=\"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security &amp; Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.\" \/>\n<meta name=\"robots\" content=\"index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1\" \/>\n<link rel=\"canonical\" href=\"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/\" \/>\n<meta property=\"og:locale\" content=\"en_US\" \/>\n<meta property=\"og:type\" content=\"article\" \/>\n<meta property=\"og:title\" content=\"Frozen in transit: Secret Blizzard\u2019s AiTM campaign against diplomats 2026 | ThreatsHub Cybersecurity News\" \/>\n<meta property=\"og:description\" content=\"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security &amp; Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.\" \/>\n<meta property=\"og:url\" content=\"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/\" \/>\n<meta property=\"og:site_name\" content=\"ThreatsHub Cybersecurity News\" \/>\n<meta property=\"article:published_time\" content=\"2025-07-31T16:00:00+00:00\" \/>\n<meta property=\"og:image\" content=\"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/05\/Threatshub_Favicon1.jpg\" \/>\n\t<meta property=\"og:image:width\" content=\"432\" \/>\n\t<meta property=\"og:image:height\" content=\"435\" \/>\n\t<meta property=\"og:image:type\" content=\"image\/jpeg\" \/>\n<meta name=\"author\" content=\"TH Author\" \/>\n<meta name=\"twitter:card\" content=\"summary_large_image\" \/>\n<meta name=\"twitter:creator\" content=\"@threatshub\" \/>\n<meta name=\"twitter:site\" content=\"@threatshub\" \/>\n<meta name=\"twitter:label1\" content=\"Written by\" \/>\n\t<meta name=\"twitter:data1\" content=\"TH Author\" \/>\n\t<meta name=\"twitter:label2\" content=\"Est. reading time\" \/>\n\t<meta name=\"twitter:data2\" content=\"16 minutes\" \/>\n<script type=\"application\/ld+json\" class=\"yoast-schema-graph\">{\"@context\":\"https:\\\/\\\/schema.org\",\"@graph\":[{\"@type\":\"Article\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\\\/#article\",\"isPartOf\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\\\/\"},\"author\":{\"name\":\"TH Author\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#\\\/schema\\\/person\\\/12e0a8671ff89a863584f193e7062476\"},\"headline\":\"Frozen in transit: Secret Blizzard\u2019s AiTM campaign against diplomats\",\"datePublished\":\"2025-07-31T16:00:00+00:00\",\"mainEntityOfPage\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\\\/\"},\"wordCount\":2888,\"publisher\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#organization\"},\"image\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\\\/#primaryimage\"},\"thumbnailUrl\":\"https:\\\/\\\/www.microsoft.com\\\/en-us\\\/security\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/07\\\/Figure-1.-Secret-Blizzard-AiTM-infection-chain-1.webp\",\"articleSection\":[\"Microsoft Secure\"],\"inLanguage\":\"en-US\"},{\"@type\":\"WebPage\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\\\/\",\"url\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\\\/\",\"name\":\"Frozen in transit: Secret Blizzard\u2019s AiTM campaign against diplomats 2026 | ThreatsHub Cybersecurity News\",\"isPartOf\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#website\"},\"primaryImageOfPage\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\\\/#primaryimage\"},\"image\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\\\/#primaryimage\"},\"thumbnailUrl\":\"https:\\\/\\\/www.microsoft.com\\\/en-us\\\/security\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/07\\\/Figure-1.-Secret-Blizzard-AiTM-infection-chain-1.webp\",\"datePublished\":\"2025-07-31T16:00:00+00:00\",\"description\":\"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security & Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.\",\"breadcrumb\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\\\/#breadcrumb\"},\"inLanguage\":\"en-US\",\"potentialAction\":[{\"@type\":\"ReadAction\",\"target\":[\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\\\/\"]}]},{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\\\/#primaryimage\",\"url\":\"https:\\\/\\\/www.microsoft.com\\\/en-us\\\/security\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/07\\\/Figure-1.-Secret-Blizzard-AiTM-infection-chain-1.webp\",\"contentUrl\":\"https:\\\/\\\/www.microsoft.com\\\/en-us\\\/security\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/07\\\/Figure-1.-Secret-Blizzard-AiTM-infection-chain-1.webp\"},{\"@type\":\"BreadcrumbList\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\\\/#breadcrumb\",\"itemListElement\":[{\"@type\":\"ListItem\",\"position\":1,\"name\":\"Home\",\"item\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/\"},{\"@type\":\"ListItem\",\"position\":2,\"name\":\"Frozen in transit: Secret Blizzard\u2019s AiTM campaign against diplomats\"}]},{\"@type\":\"WebSite\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#website\",\"url\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/\",\"name\":\"ThreatsHub Cybersecurity News\",\"description\":\"%%focuskw%% Threat Intel \u2013 Threat Intel Services \u2013 CyberIntelligence \u2013 Cyber Threat Intelligence - Threat Intelligence Feeds - Threat Intelligence Reports - CyberSecurity Report \u2013 Cyber Security PDF \u2013 Cybersecurity Trends - Cloud Sandbox \u2013- Threat IntelligencePortal \u2013 Incident Response \u2013 Threat Hunting \u2013 IOC - Yara - Security Operations Center \u2013 SecurityOperation Center \u2013 Security SOC \u2013 SOC Services - Advanced Threat - Threat Detection - TargetedAttack \u2013 APT \u2013 Anti-APT \u2013 Advanced Protection \u2013 Cyber Security Services \u2013 Cybersecurity Services -Threat Intelligence Platform\",\"publisher\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#organization\"},\"alternateName\":\"Threatshub.org\",\"potentialAction\":[{\"@type\":\"SearchAction\",\"target\":{\"@type\":\"EntryPoint\",\"urlTemplate\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/?s={search_term_string}\"},\"query-input\":{\"@type\":\"PropertyValueSpecification\",\"valueRequired\":true,\"valueName\":\"search_term_string\"}}],\"inLanguage\":\"en-US\"},{\"@type\":\"Organization\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#organization\",\"name\":\"ThreatsHub.org\",\"alternateName\":\"Threatshub.org\",\"url\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/\",\"logo\":{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#\\\/schema\\\/logo\\\/image\\\/\",\"url\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/05\\\/Threatshub_Favicon1.jpg\",\"contentUrl\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/05\\\/Threatshub_Favicon1.jpg\",\"width\":432,\"height\":435,\"caption\":\"ThreatsHub.org\"},\"image\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#\\\/schema\\\/logo\\\/image\\\/\"},\"sameAs\":[\"https:\\\/\\\/x.com\\\/threatshub\"]},{\"@type\":\"Person\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#\\\/schema\\\/person\\\/12e0a8671ff89a863584f193e7062476\",\"name\":\"TH Author\",\"image\":{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\\\/\\\/secure.gravatar.com\\\/avatar\\\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g\",\"url\":\"https:\\\/\\\/secure.gravatar.com\\\/avatar\\\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g\",\"contentUrl\":\"https:\\\/\\\/secure.gravatar.com\\\/avatar\\\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g\",\"caption\":\"TH Author\"}}]}<\/script>\n<!-- \/ Yoast SEO plugin. -->","yoast_head_json":{"title":"Frozen in transit: Secret Blizzard\u2019s AiTM campaign against diplomats 2026 | ThreatsHub Cybersecurity News","description":"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security & Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.","robots":{"index":"index","follow":"follow","max-snippet":"max-snippet:-1","max-image-preview":"max-image-preview:large","max-video-preview":"max-video-preview:-1"},"canonical":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/","og_locale":"en_US","og_type":"article","og_title":"Frozen in transit: Secret Blizzard\u2019s AiTM campaign against diplomats 2026 | ThreatsHub Cybersecurity News","og_description":"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security & Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.","og_url":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/","og_site_name":"ThreatsHub Cybersecurity News","article_published_time":"2025-07-31T16:00:00+00:00","og_image":[{"width":432,"height":435,"url":"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/05\/Threatshub_Favicon1.jpg","type":"image\/jpeg"}],"author":"TH Author","twitter_card":"summary_large_image","twitter_creator":"@threatshub","twitter_site":"@threatshub","twitter_misc":{"Written by":"TH Author","Est. reading time":"16 minutes"},"schema":{"@context":"https:\/\/schema.org","@graph":[{"@type":"Article","@id":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/#article","isPartOf":{"@id":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/"},"author":{"name":"TH Author","@id":"https:\/\/www.threatshub.org\/blog\/#\/schema\/person\/12e0a8671ff89a863584f193e7062476"},"headline":"Frozen in transit: Secret Blizzard\u2019s AiTM campaign against diplomats","datePublished":"2025-07-31T16:00:00+00:00","mainEntityOfPage":{"@id":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/"},"wordCount":2888,"publisher":{"@id":"https:\/\/www.threatshub.org\/blog\/#organization"},"image":{"@id":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/#primaryimage"},"thumbnailUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/Figure-1.-Secret-Blizzard-AiTM-infection-chain-1.webp","articleSection":["Microsoft Secure"],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/","url":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/","name":"Frozen in transit: Secret Blizzard\u2019s AiTM campaign against diplomats 2026 | ThreatsHub Cybersecurity News","isPartOf":{"@id":"https:\/\/www.threatshub.org\/blog\/#website"},"primaryImageOfPage":{"@id":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/#primaryimage"},"image":{"@id":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/#primaryimage"},"thumbnailUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/Figure-1.-Secret-Blizzard-AiTM-infection-chain-1.webp","datePublished":"2025-07-31T16:00:00+00:00","description":"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security & Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.","breadcrumb":{"@id":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/#primaryimage","url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/Figure-1.-Secret-Blizzard-AiTM-infection-chain-1.webp","contentUrl":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/07\/Figure-1.-Secret-Blizzard-AiTM-infection-chain-1.webp"},{"@type":"BreadcrumbList","@id":"https:\/\/www.threatshub.org\/blog\/frozen-in-transit-secret-blizzards-aitm-campaign-against-diplomats\/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https:\/\/www.threatshub.org\/blog\/"},{"@type":"ListItem","position":2,"name":"Frozen in transit: Secret Blizzard\u2019s AiTM campaign against diplomats"}]},{"@type":"WebSite","@id":"https:\/\/www.threatshub.org\/blog\/#website","url":"https:\/\/www.threatshub.org\/blog\/","name":"ThreatsHub Cybersecurity News","description":"%%focuskw%% Threat Intel \u2013 Threat Intel Services \u2013 CyberIntelligence \u2013 Cyber Threat Intelligence - Threat Intelligence Feeds - Threat Intelligence Reports - CyberSecurity Report \u2013 Cyber Security PDF \u2013 Cybersecurity Trends - Cloud Sandbox \u2013- Threat IntelligencePortal \u2013 Incident Response \u2013 Threat Hunting \u2013 IOC - Yara - Security Operations Center \u2013 SecurityOperation Center \u2013 Security SOC \u2013 SOC Services - Advanced Threat - Threat Detection - TargetedAttack \u2013 APT \u2013 Anti-APT \u2013 Advanced Protection \u2013 Cyber Security Services \u2013 Cybersecurity Services -Threat Intelligence Platform","publisher":{"@id":"https:\/\/www.threatshub.org\/blog\/#organization"},"alternateName":"Threatshub.org","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https:\/\/www.threatshub.org\/blog\/?s={search_term_string}"},"query-input":{"@type":"PropertyValueSpecification","valueRequired":true,"valueName":"search_term_string"}}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https:\/\/www.threatshub.org\/blog\/#organization","name":"ThreatsHub.org","alternateName":"Threatshub.org","url":"https:\/\/www.threatshub.org\/blog\/","logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/www.threatshub.org\/blog\/#\/schema\/logo\/image\/","url":"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/05\/Threatshub_Favicon1.jpg","contentUrl":"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/05\/Threatshub_Favicon1.jpg","width":432,"height":435,"caption":"ThreatsHub.org"},"image":{"@id":"https:\/\/www.threatshub.org\/blog\/#\/schema\/logo\/image\/"},"sameAs":["https:\/\/x.com\/threatshub"]},{"@type":"Person","@id":"https:\/\/www.threatshub.org\/blog\/#\/schema\/person\/12e0a8671ff89a863584f193e7062476","name":"TH Author","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/secure.gravatar.com\/avatar\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g","url":"https:\/\/secure.gravatar.com\/avatar\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g","contentUrl":"https:\/\/secure.gravatar.com\/avatar\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g","caption":"TH Author"}}]}},"_links":{"self":[{"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/posts\/59103","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/users\/2"}],"replies":[{"embeddable":true,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/comments?post=59103"}],"version-history":[{"count":0,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/posts\/59103\/revisions"}],"wp:attachment":[{"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/media?parent=59103"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/categories?post=59103"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/tags?post=59103"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}