{"id":58447,"date":"2025-04-08T18:00:00","date_gmt":"2025-04-08T18:00:00","guid":{"rendered":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/"},"modified":"2025-04-08T18:00:00","modified_gmt":"2025-04-08T18:00:00","slug":"exploitation-of-clfs-zero-day-leads-to-ransomware-activity","status":"publish","type":"post","link":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/","title":{"rendered":"Exploitation of CLFS zero-day leads to ransomware activity"},"content":{"rendered":"<div><img decoding=\"async\" src=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/04\/CVE-2025-29824-exploitation.png\" class=\"ff-og-image-inserted\"><\/div>\n<p>Microsoft Threat Intelligence Center (MSTIC) and Microsoft Security Response Center (MSRC) have discovered post-compromise exploitation of a zero-day elevation of privilege vulnerability in the Windows Common Log File System (CLFS) against a small number of targets. The targets include organizations in the information technology (IT) and real estate sectors of the United States, the financial sector in Venezuela, a Spanish software company, and the retail sector in Saudi Arabia. Microsoft released security updates to address the vulnerability, tracked as <a href=\"https:\/\/msrc.microsoft.com\/update-guide\/vulnerability\/CVE-2025-29824\">CVE-2025-29824<\/a>, on April 8, 2025.<\/p>\n<p>In addition to discovering the vulnerability, Microsoft also found that the exploit has been deployed by PipeMagic malware. Microsoft is attributing the exploitation activity to Storm-2460, which also used PipeMagic to deploy ransomware. Ransomware threat actors value post-compromise elevation of privilege exploits because these could enable them to escalate initial access, including handoffs from commodity malware distributors, into privileged access. They then use privileged access for widespread deployment and detonation of ransomware within an environment. Microsoft highly recommends that organizations prioritize applying security updates for elevation of privilege vulnerabilities to add a layer of defense against ransomware attacks if threat actors are able to gain an initial foothold.<\/p>\n<p>This blog details Microsoft\u2019s analysis of the observed CLFS exploit and related activity targeting our customers. This information is shared with our customers and industry partners to improve detection of these attacks and encourage rapid patching or other mitigations, as appropriate. A more comprehensive recommendations section, with indicators of compromise and detection details can be found at the end of the blog post.<\/p>\n<h2 class=\"wp-block-heading\" id=\"cve-2025-29824-a-zero-day-vulnerability-in-the-common-log-file-system-clfs\">CVE 2025-29824: A zero-day vulnerability in the Common Log File System (CLFS)<\/h2>\n<p>The exploit activity discovered by Microsoft targets a zero-day vulnerability in the Common Log File System (CLFS) kernel driver. Successful exploitation allows an attacker running as a standard user account to escalate privileges. The vulnerability is tracked as <a href=\"https:\/\/msrc.microsoft.com\/update-guide\/vulnerability\/CVE-2025-29824\">CVE-2025-29824<\/a> and was fixed on April 8, 2025.<\/p>\n<h3 class=\"wp-block-heading\" id=\"pre-exploitation-activity\">Pre-exploitation activity<\/h3>\n<p>While Microsoft hasn\u2019t determined the initial access vectors that led to the devices being compromised, there are some notable pre-exploitation behaviors by Storm-2460. In multiple cases, the threat actor used the certutil utility to download a file from a legitimate third-party website that was previously compromised to host the threat actor\u2019s malware.<\/p>\n<p>The downloaded file was a malicious MSBuild file, a technique described <a href=\"https:\/\/blog.talosintelligence.com\/building-bypass-with-msbuild\/\">here<\/a>, that carried an encrypted malware payload. Once the payload was decrypted and executed via the <em>EnumCalendarInfoA<\/em> API callback, the malware was found to be <a href=\"https:\/\/www.kaspersky.com\/about\/press-releases\/kaspersky-uncovers-pipemagic-backdoor-attacks-businesses-through-fake-chatgpt-application\">PipeMagic,<\/a> which Kaspersky documented in October 2024<em>. <\/em>Researchers at <a href=\"https:\/\/x.com\/ESETresearch\/status\/1899508656258875756\">ESET have also observed<\/a> the use of PipeMagic in 2023 in connection with the deployment of a zero-day exploit for a Win32k vulnerability assigned <a href=\"https:\/\/msrc.microsoft.com\/update-guide\/vulnerability\/CVE-2025-24983\">CVE-2025-24983<\/a>. A domain used by the PipeMagic sample was <em>aaaaabbbbbbb.eastus.cloudapp.azure[.]com, <\/em>which has now been disabled by Microsoft.<\/p>\n<h3 class=\"wp-block-heading\" id=\"clfs-exploit-activity\">CLFS exploit activity<\/h3>\n<p>Following PipeMagic deployment, the attackers launched the CLFS exploit in memory from a <em>dllhost.exe <\/em>process.<\/p>\n<p>The exploit targets a vulnerability in the CLFS kernel driver. It\u2019s notable that the exploit first uses the <em>NtQuerySystemInformation <\/em>API to leak kernel addresses to user mode. However, beginning in Windows 11, version 24H2, access to certain System Information Classes within <em>NtQuerySystemInformation <\/em>became available only to users with <em>SeDebugPrivilege<\/em>, which typically only admin-like users can obtain. This meant that the exploit did not work on Windows 11, version 24H2, even if the vulnerability was present.<\/p>\n<p>The exploit then utilizes a memory corruption and the <em>RtlSetAllBits <\/em>API to overwrite the exploit process\u2019s token with the value 0xFFFFFFFF, enabling all privileges for the process, which allows for process injection into SYSTEM processes.<\/p>\n<p>As part of the exploitation, a CLFS BLF file with the following path is created by the exploit\u2019s <em>dllhost.exe<\/em> process: <em>C:\\ProgramData\\SkyPDF\\PDUDrv.blf<\/em>. <\/p>\n<h3 class=\"wp-block-heading\" id=\"post-exploitation-activity-leads-to-ransomware-activity\">Post-exploitation activity leads to ransomware activity<\/h3>\n<p>Upon successful exploitation, a payload is injected into <em>winlogon.exe. <\/em>This payload then injected the Sysinternals <a href=\"https:\/\/learn.microsoft.com\/en-us\/sysinternals\/downloads\/procdump#using-procdump\"><em>procdump.exe<\/em><\/a> tool into another <em>dllhost.exe <\/em>and ran it with the following command line:<\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"7\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nC:\\Windows\\system32\\dllhost.exe -accepteula -r -ma lsass.exe c:\\programdata\\[random letters].\n<\/pre>\n<\/div>\n<p>Having done this, the actor was able to dump the memory of LSASS and parse it to obtain user credentials.<\/p>\n<p>Then, Microsoft observed ransomware activity on target systems. Files were encrypted and a random extension added, and a ransom note with the name <em>!_READ_ME_REXX2_!.txt<\/em> was dropped. Microsoft is tracking activity associated with this ransomware as Storm-2460.<\/p>\n<p>Although we weren\u2019t able to obtain a sample of ransomware for analysis, we\u2019re including some notable events surrounding the activity to better help defenders:<\/p>\n<ul class=\"wp-block-list\">\n<li>Two .onion domains have been seen in the <em>!_READ_ME_REXX2_!.txt <\/em>ransom notes\n<ul class=\"wp-block-list\">\n<li><em>uyhi3ypdkfeymyf5v35pbk3pz7st3zamsbjzf47jiqbcm3zmikpwf3qd.onion<\/em><\/li>\n<\/ul>\n<\/li>\n<li>The ransomware is launched from <em>dllhost.exe<\/em> with the command line:<\/li>\n<\/ul>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"8\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; notranslate\" title>\n--do [path_to_ransom] (for example, C:\\Windows\\system32\\dllhost.exe --do C:\\foobar)\n<\/pre>\n<\/div>\n<ul class=\"wp-block-list\">\n<li>The file extension on the encrypted files is random per device, but the same for every file<\/li>\n<li>Some typical ransomware commands that make recovery or analysis harder are executed, including:\n<ul>\n<li><em>bcdedit \/set {default} recoveryenabled no<\/em><\/li>\n<\/ul>\n<ul>\n<li><em>wbadmin delete catalog -quiet<\/em><\/li>\n<\/ul>\n<ul class=\"wp-block-list\">\n<li><em>wevtutil cl Application<\/em><\/li>\n<\/ul>\n<\/li>\n<li>In one observed case the actor spawned <em>notepad.exe <\/em>as SYSTEM<\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\" id=\"mitigation-and-protection-guidance\">Mitigation and protection guidance<\/h2>\n<p>Microsoft released security updates to address CVE 2025-29824 on April 8, 2025. Customers running Windows 11, version 24H2 are not affected by the observed exploitation, even if the vulnerability was present. Microsoft urges customers to apply these updates as soon as possible.<\/p>\n<p>Microsoft recommends the following mitigations to reduce the impact of activity associated with Storm-2460:<\/p>\n<ul class=\"wp-block-list\">\n<li>Refer to our blog&nbsp;<a href=\"https:\/\/www.microsoft.com\/security\/blog\/2022\/05\/09\/ransomware-as-a-service-understanding-the-cybercrime-gig-economy-and-how-to-protect-yourself\/#defending-against-ransomware\">Ransomware as a service: Understanding the cybercrime gig economy<\/a>&nbsp;and how to protect yourself for robust measures to defend against ransomware.<\/li>\n<li>Turn on <a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/configure-block-at-first-sight-microsoft-defender-antivirus\" target=\"_blank\" rel=\"noreferrer noopener\">cloud-delivered protection<\/a> in Microsoft Defender Antivirus or the equivalent for your antivirus product to cover rapidly evolving attacker tools and techniques. Cloud-based machine learning protections block a majority of new and unknown variants.<\/li>\n<li>Use&nbsp;<a href=\"https:\/\/learn.microsoft.com\/en-us\/microsoft-365\/security\/defender-endpoint\/device-discovery?view=o365-worldwide\">device discovery<\/a>&nbsp;to increase your visibility into your network by finding unmanaged devices on your network and onboarding them to Microsoft Defender for Endpoint. Ransomware attackers often identify unmanaged or legacy systems and use these blind spots to stage attacks.<\/li>\n<li>Run <a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/edr-in-block-mode\" target=\"_blank\" rel=\"noreferrer noopener\">EDR in block mode<\/a>&nbsp;so that Microsoft Defender for Endpoint can block malicious artifacts, even when your non-Microsoft antivirus doesn\u2019t detect the threat or when Microsoft Defender Antivirus is running in passive mode. EDR in block mode works behind the scenes to remediate malicious artifacts that are detected post-breach.<\/li>\n<li>Enable <a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/automated-investigations\">investigation and remediation<\/a> in full automated mode to allow Microsoft Defender for Endpoint to take immediate action on alerts to resolve breaches, significantly reducing alert volume. Use&nbsp;<a href=\"https:\/\/security.microsoft.com\/vulnerabilities\">Microsoft Defender Vulnerability Management<\/a>&nbsp;to assess your current status and deploy any updates that might have been missed.<\/li>\n<li>Microsoft 365 Defender customers can turn on <a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/attack-surface-reduction\" target=\"_blank\" rel=\"noreferrer noopener\">attack surface reduction rules<\/a>&nbsp;to prevent common attack techniques used in ransomware attacks:<\/li>\n<li><a href=\"https:\/\/learn.microsoft.com\/microsoft-365\/security\/defender-endpoint\/attack-surface-reduction-rules-reference#use-advanced-protection-against-ransomware\" target=\"_blank\" rel=\"noreferrer noopener\">Use advanced protection against ransomware<\/a><\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\" id=\"microsoft-defender-xdr-detections\">Microsoft Defender XDR detections<\/h2>\n<p>Microsoft Defender XDR customers can refer to the list of applicable detections below. Microsoft Defender XDR coordinates detection, prevention, investigation, and response across endpoints, identities, email, apps to provide integrated protection against attacks like the threat discussed in this blog.<\/p>\n<p>Customers with provisioned access can also use <a href=\"https:\/\/learn.microsoft.com\/en-us\/defender-xdr\/security-copilot-in-microsoft-365-defender\">Microsoft Security Copilot in Microsoft Defender<\/a> to investigate and respond to incidents, hunt for threats, and protect their organization with relevant threat intelligence.<\/p>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-antivirus\">Microsoft Defender Antivirus<\/h3>\n<p>Microsoft Defender Antivirus detects threats associated with this activity as the following malware:<\/p>\n<ul class=\"wp-block-list\">\n<li>SilverBasket (Win64\/Windows)<\/li>\n<li>MSBuildInlineTaskLoader.C (Script\/Windows)<\/li>\n<li>SuspClfsAccess (Win32\/Windows)<\/li>\n<\/ul>\n<h3 class=\"wp-block-heading\" id=\"microsoft-defender-for-endpoint\">Microsoft Defender for Endpoint<\/h3>\n<p>The following alerts might indicate threat activity related to this threat. Note, however, that these alerts can be also triggered by unrelated threat activity.<\/p>\n<ul class=\"wp-block-list\">\n<li>A process was injected with potentially malicious code<\/li>\n<li>Potential Windows DLL process injection<\/li>\n<li>Suspicious access to LSASS service<\/li>\n<li>Sensitive credential memory read<\/li>\n<li>Suspicious process injection observed<\/li>\n<li>File backups were deleted<\/li>\n<li>Ransomware behavior detected in the file system<\/li>\n<\/ul>\n<h2 class=\"wp-block-heading\" id=\"microsoft-security-copilot\">Microsoft Security Copilot<\/h2>\n<p>Security Copilot customers can use the standalone experience to <a href=\"https:\/\/learn.microsoft.com\/en-us\/copilot\/security\/prompting-security-copilot#create-your-own-prompts\">create their own prompts<\/a> or run the following <a href=\"https:\/\/learn.microsoft.com\/en-us\/copilot\/security\/using-promptbooks\">pre-built promptbooks<\/a> to automate incident response or investigation tasks related to this threat:<\/p>\n<ul class=\"wp-block-list\">\n<li>Incident investigation<\/li>\n<li>Microsoft User analysis<\/li>\n<li>Threat actor profile<\/li>\n<li>Threat Intelligence 360 report based on MDTI article<\/li>\n<li>Vulnerability impact assessment<\/li>\n<\/ul>\n<p>Note that some promptbooks require access to plugins for Microsoft products such as Microsoft Defender XDR or Microsoft Sentinel.<\/p>\n<h2 class=\"wp-block-heading\" id=\"hunting-queries\">Hunting queries<\/h2>\n<h3 class=\"wp-block-heading\" id=\"microsoft-sentinel\">Microsoft Sentinel<\/h3>\n<p>Microsoft Sentinel customers can use the TI Mapping analytics (a series of analytics all prefixed with \u2018TI map\u2019) to automatically match the malicious domain indicators mentioned in this blog post with data in their workspace. If the TI Map analytics are not currently deployed, customers can install the Threat Intelligence solution from the <a href=\"https:\/\/learn.microsoft.com\/azure\/sentinel\/sentinel-solutions-deploy\">Microsoft Sentinel Content Hub<\/a> to have the analytics rule deployed in their Sentinel workspace.<\/p>\n<p><strong>Search for devices having CVE-2025-29814 exposure<\/strong><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"37\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nDeviceTvmSoftwareVulnerabilities\n| where CveId in (\"CVE-2025-29814\")\n| project DeviceId,DeviceName,OSPlatform,OSVersion,SoftwareVendor,SoftwareName,SoftwareVersion,\nCveId,VulnerabilitySeverityLevel\n| join kind=inner ( DeviceTvmSoftwareVulnerabilitiesKB | project CveId, CvssScore,IsExploitAvailable,VulnerabilitySeverityLevel,PublishedDate,VulnerabilityDescription,AffectedSoftware ) on CveId\n| project DeviceId,DeviceName,OSPlatform,OSVersion,SoftwareVendor,SoftwareName,SoftwareVersion,\nCveId,VulnerabilitySeverityLevel,CvssScore,IsExploitAvailable,PublishedDate,VulnerabilityDescription,AffectedSoftware\n<\/pre>\n<\/div>\n<p><strong>Detect CLFS BLF file creation after exploitation of CVE 2025-29824<\/strong><strong><\/strong><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"7\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nDeviceFileEvents | where FolderPath has \"C:\\\\ProgramData\\\\SkyPDF\\\\\" and FileName endswith \".blf\"\n<\/pre>\n<\/div>\n<p><strong>LSSASS process dumping activity<\/strong><strong><\/strong><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"11\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nSecurityEvent | where EventID == 4688 | where CommandLine has(\"dllhost.exe -accepteula -r -ma lsass.exe\") | extend timestamp = TimeGenerated, AccountCustomEntity = Account, HostCustomEntity = Computer\n<\/pre>\n<\/div>\n<p><strong>Ransomware process activity<\/strong><strong><\/strong><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"17\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nlet cmdlines = dynamic([\"C:\\\\Windows\\\\system32\\\\dllhost.exe --do\",\"bcdedit \/set {default} recoveryenabled no\",\"wbadmin delete catalog -quiet\",\"wevtutil cl Application\"]);\nDeviceProcessEvents | where ProcessCommandLine has_any (cmdlines)\n| project TimeGenerated, DeviceName, ProcessCommandLine, AccountDomain, AccountName\n<\/pre>\n<\/div>\n<p><strong>PipeMagic and RansomEXX fansomware domains<\/strong><strong><\/strong><\/p>\n<div class=\"wp-block-syntaxhighlighter-code \" readability=\"22\">\n<pre class=\"brush: plain; auto-links: false; gutter: false; title: ; quick-code: false; notranslate\" title>\nlet domains = dynamic([\"aaaaabbbbbbb.eastus.cloudapp.azure.com\",\"jbdg4buq6jd7ed3rd6cynqtq5abttuekjnxqrqyvk4xam5i7ld33jvqd.onion\",\"uyhi3ypdkfeymyf5v35pbk3pz7st3zamsbjzf47jiqbcm3zmikpwf3qd.onion\"]);\nDeviceNetworkEvents\n| where RemoteUrl has_any (domains)\n| project TimeGenerated, DeviceId, DeviceName, Protocol, LocalIP, LocalIPType, LocalPort,RemoteIP, RemoteIPType, RemotePort, RemoteUrl\n<\/pre>\n<\/div>\n<h2 class=\"wp-block-heading\" id=\"indicators-of-compromise\">Indicators of compromise<\/h2>\n<figure class=\"wp-block-table table\">\n<table class=\"has-fixed-layout\">\n<tbody readability=\"6\">\n<tr>\n<td><strong>Indicator<\/strong><\/td>\n<td><strong>Type<\/strong><\/td>\n<td><strong>Description<\/strong><\/td>\n<\/tr>\n<tr readability=\"4\">\n<td>C:\\ProgramData\\SkyPDF\\PDUDrv.blf<\/td>\n<td>Path<\/td>\n<td>Dropped during CLFS exploit<\/td>\n<\/tr>\n<tr readability=\"2\">\n<td>C:\\Windows\\system32\\dllhost.exe \u2013do<\/td>\n<td>Command line<\/td>\n<td>Injected dllhost<\/td>\n<\/tr>\n<tr readability=\"2\">\n<td>bcdedit \/set {default} recoveryenabled no<\/td>\n<td>Command line<\/td>\n<td>Ransomware command<\/td>\n<\/tr>\n<tr readability=\"2\">\n<td>wbadmin delete catalog -quiet<\/td>\n<td>Command line<\/td>\n<td>Ransomware command<\/td>\n<\/tr>\n<tr>\n<td>wevtutil cl Application<\/td>\n<td>Command line<\/td>\n<td>Ransomware command<\/td>\n<\/tr>\n<tr readability=\"2\">\n<td>aaaaabbbbbbb.eastus.cloudapp.azure[.]com<\/td>\n<td>Domain<\/td>\n<td>Used by PipeMagic<\/td>\n<\/tr>\n<\/tbody>\n<\/table>\n<\/figure>\n<h2 class=\"wp-block-heading\" id=\"references\">References<\/h2>\n<h2 class=\"wp-block-heading\" id=\"learn-more\">Learn more<\/h2>\n<p>For the latest security research from the Microsoft Threat Intelligence community, check out the Microsoft Threat Intelligence Blog:&nbsp;<a href=\"https:\/\/aka.ms\/threatintelblog\">https:\/\/aka.ms\/threatintelblog<\/a>.<\/p>\n<p>To get notified about new publications and to join discussions on social media, follow us on LinkedIn at <a href=\"https:\/\/www.linkedin.com\/showcase\/microsoft-threat-intelligence\">https:\/\/www.linkedin.com\/showcase\/microsoft-threat-intelligence<\/a>, and on X (formerly Twitter) at&nbsp;<a href=\"https:\/\/x.com\/MsftSecIntel\" target=\"_blank\" rel=\"noreferrer noopener\">https:\/\/x.com\/MsftSecIntel<\/a>.<\/p>\n<p>To hear stories and insights from the Microsoft Threat Intelligence community about the ever-evolving threat landscape, listen to the Microsoft Threat Intelligence podcast: <a href=\"https:\/\/thecyberwire.com\/podcasts\/microsoft-threat-intelligence\">https:\/\/thecyberwire.com\/podcasts\/microsoft-threat-intelligence<\/a>.<\/p>\n<p> READ MORE <a href=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/2025\/04\/08\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/\">HERE<\/a><\/p>\n","protected":false},"excerpt":{"rendered":"<p>Microsoft Threat Intelligence Center (MSTIC) and Microsoft Security Response Center (MSRC) have discovered post-compromise exploitation of a newly discovered zero-day vulnerability in the Windows Common Log File System (CLFS) against a small number of targets. Microsoft released security updates to address the vulnerability, tracked as CVE 2025-29824, on April 8, 2025.<br \/>\nThe post Exploitation of CLFS zero-day leads to ransomware activity appeared first on Microsoft Security Blog. READ MORE HERE&#8230;<\/p>\n","protected":false},"author":2,"featured_media":58448,"comment_status":"closed","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"colormag_page_layout":"default_layout","footnotes":""},"categories":[276],"tags":[],"class_list":["post-58447","post","type-post","status-publish","format-standard","has-post-thumbnail","hentry","category-microsoft-secure"],"yoast_head":"<!-- This site is optimized with the Yoast SEO plugin v27.9 - https:\/\/yoast.com\/product\/yoast-seo-wordpress\/ -->\n<title>Exploitation of CLFS zero-day leads to ransomware activity 2026 | ThreatsHub Cybersecurity News<\/title>\n<meta name=\"description\" content=\"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security &amp; Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.\" \/>\n<meta name=\"robots\" content=\"index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1\" \/>\n<link rel=\"canonical\" href=\"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/\" \/>\n<meta property=\"og:locale\" content=\"en_US\" \/>\n<meta property=\"og:type\" content=\"article\" \/>\n<meta property=\"og:title\" content=\"Exploitation of CLFS zero-day leads to ransomware activity 2026 | ThreatsHub Cybersecurity News\" \/>\n<meta property=\"og:description\" content=\"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security &amp; Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.\" \/>\n<meta property=\"og:url\" content=\"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/\" \/>\n<meta property=\"og:site_name\" content=\"ThreatsHub Cybersecurity News\" \/>\n<meta property=\"article:published_time\" content=\"2025-04-08T18:00:00+00:00\" \/>\n<meta property=\"og:image\" content=\"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/04\/CVE-2025-29824-exploitation.png\" \/>\n<meta name=\"author\" content=\"TH Author\" \/>\n<meta name=\"twitter:card\" content=\"summary_large_image\" \/>\n<meta name=\"twitter:creator\" content=\"@threatshub\" \/>\n<meta name=\"twitter:site\" content=\"@threatshub\" \/>\n<meta name=\"twitter:label1\" content=\"Written by\" \/>\n\t<meta name=\"twitter:data1\" content=\"TH Author\" \/>\n\t<meta name=\"twitter:label2\" content=\"Est. reading time\" \/>\n\t<meta name=\"twitter:data2\" content=\"9 minutes\" \/>\n<script type=\"application\/ld+json\" class=\"yoast-schema-graph\">{\"@context\":\"https:\\\/\\\/schema.org\",\"@graph\":[{\"@type\":\"Article\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\\\/#article\",\"isPartOf\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\\\/\"},\"author\":{\"name\":\"TH Author\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#\\\/schema\\\/person\\\/12e0a8671ff89a863584f193e7062476\"},\"headline\":\"Exploitation of CLFS zero-day leads to ransomware activity\",\"datePublished\":\"2025-04-08T18:00:00+00:00\",\"mainEntityOfPage\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\\\/\"},\"wordCount\":1606,\"publisher\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#organization\"},\"image\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\\\/#primaryimage\"},\"thumbnailUrl\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/04\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity.png\",\"articleSection\":[\"Microsoft Secure\"],\"inLanguage\":\"en-US\"},{\"@type\":\"WebPage\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\\\/\",\"url\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\\\/\",\"name\":\"Exploitation of CLFS zero-day leads to ransomware activity 2026 | ThreatsHub Cybersecurity News\",\"isPartOf\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#website\"},\"primaryImageOfPage\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\\\/#primaryimage\"},\"image\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\\\/#primaryimage\"},\"thumbnailUrl\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/04\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity.png\",\"datePublished\":\"2025-04-08T18:00:00+00:00\",\"description\":\"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security & Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.\",\"breadcrumb\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\\\/#breadcrumb\"},\"inLanguage\":\"en-US\",\"potentialAction\":[{\"@type\":\"ReadAction\",\"target\":[\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\\\/\"]}]},{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\\\/#primaryimage\",\"url\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/04\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity.png\",\"contentUrl\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/04\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity.png\",\"width\":1200,\"height\":674},{\"@type\":\"BreadcrumbList\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\\\/#breadcrumb\",\"itemListElement\":[{\"@type\":\"ListItem\",\"position\":1,\"name\":\"Home\",\"item\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/\"},{\"@type\":\"ListItem\",\"position\":2,\"name\":\"Exploitation of CLFS zero-day leads to ransomware activity\"}]},{\"@type\":\"WebSite\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#website\",\"url\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/\",\"name\":\"ThreatsHub Cybersecurity News\",\"description\":\"%%focuskw%% Threat Intel \u2013 Threat Intel Services \u2013 CyberIntelligence \u2013 Cyber Threat Intelligence - Threat Intelligence Feeds - Threat Intelligence Reports - CyberSecurity Report \u2013 Cyber Security PDF \u2013 Cybersecurity Trends - Cloud Sandbox \u2013- Threat IntelligencePortal \u2013 Incident Response \u2013 Threat Hunting \u2013 IOC - Yara - Security Operations Center \u2013 SecurityOperation Center \u2013 Security SOC \u2013 SOC Services - Advanced Threat - Threat Detection - TargetedAttack \u2013 APT \u2013 Anti-APT \u2013 Advanced Protection \u2013 Cyber Security Services \u2013 Cybersecurity Services -Threat Intelligence Platform\",\"publisher\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#organization\"},\"alternateName\":\"Threatshub.org\",\"potentialAction\":[{\"@type\":\"SearchAction\",\"target\":{\"@type\":\"EntryPoint\",\"urlTemplate\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/?s={search_term_string}\"},\"query-input\":{\"@type\":\"PropertyValueSpecification\",\"valueRequired\":true,\"valueName\":\"search_term_string\"}}],\"inLanguage\":\"en-US\"},{\"@type\":\"Organization\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#organization\",\"name\":\"ThreatsHub.org\",\"alternateName\":\"Threatshub.org\",\"url\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/\",\"logo\":{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#\\\/schema\\\/logo\\\/image\\\/\",\"url\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/05\\\/Threatshub_Favicon1.jpg\",\"contentUrl\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/wp-content\\\/uploads\\\/2025\\\/05\\\/Threatshub_Favicon1.jpg\",\"width\":432,\"height\":435,\"caption\":\"ThreatsHub.org\"},\"image\":{\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#\\\/schema\\\/logo\\\/image\\\/\"},\"sameAs\":[\"https:\\\/\\\/x.com\\\/threatshub\"]},{\"@type\":\"Person\",\"@id\":\"https:\\\/\\\/www.threatshub.org\\\/blog\\\/#\\\/schema\\\/person\\\/12e0a8671ff89a863584f193e7062476\",\"name\":\"TH Author\",\"image\":{\"@type\":\"ImageObject\",\"inLanguage\":\"en-US\",\"@id\":\"https:\\\/\\\/secure.gravatar.com\\\/avatar\\\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g\",\"url\":\"https:\\\/\\\/secure.gravatar.com\\\/avatar\\\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g\",\"contentUrl\":\"https:\\\/\\\/secure.gravatar.com\\\/avatar\\\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g\",\"caption\":\"TH Author\"}}]}<\/script>\n<!-- \/ Yoast SEO plugin. -->","yoast_head_json":{"title":"Exploitation of CLFS zero-day leads to ransomware activity 2026 | ThreatsHub Cybersecurity News","description":"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security & Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.","robots":{"index":"index","follow":"follow","max-snippet":"max-snippet:-1","max-image-preview":"max-image-preview:large","max-video-preview":"max-video-preview:-1"},"canonical":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/","og_locale":"en_US","og_type":"article","og_title":"Exploitation of CLFS zero-day leads to ransomware activity 2026 | ThreatsHub Cybersecurity News","og_description":"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security & Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.","og_url":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/","og_site_name":"ThreatsHub Cybersecurity News","article_published_time":"2025-04-08T18:00:00+00:00","og_image":[{"url":"https:\/\/www.microsoft.com\/en-us\/security\/blog\/wp-content\/uploads\/2025\/04\/CVE-2025-29824-exploitation.png","type":"","width":"","height":""}],"author":"TH Author","twitter_card":"summary_large_image","twitter_creator":"@threatshub","twitter_site":"@threatshub","twitter_misc":{"Written by":"TH Author","Est. reading time":"9 minutes"},"schema":{"@context":"https:\/\/schema.org","@graph":[{"@type":"Article","@id":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/#article","isPartOf":{"@id":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/"},"author":{"name":"TH Author","@id":"https:\/\/www.threatshub.org\/blog\/#\/schema\/person\/12e0a8671ff89a863584f193e7062476"},"headline":"Exploitation of CLFS zero-day leads to ransomware activity","datePublished":"2025-04-08T18:00:00+00:00","mainEntityOfPage":{"@id":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/"},"wordCount":1606,"publisher":{"@id":"https:\/\/www.threatshub.org\/blog\/#organization"},"image":{"@id":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/#primaryimage"},"thumbnailUrl":"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/04\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity.png","articleSection":["Microsoft Secure"],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/","url":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/","name":"Exploitation of CLFS zero-day leads to ransomware activity 2026 | ThreatsHub Cybersecurity News","isPartOf":{"@id":"https:\/\/www.threatshub.org\/blog\/#website"},"primaryImageOfPage":{"@id":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/#primaryimage"},"image":{"@id":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/#primaryimage"},"thumbnailUrl":"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/04\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity.png","datePublished":"2025-04-08T18:00:00+00:00","description":"ThreatsHub Cybersecurity News | ThreatsHub.org | Cloud Security & Cyber Threats Analysis Hub. 100% Free OSINT Threat Intelligent and Cybersecurity News.","breadcrumb":{"@id":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/#primaryimage","url":"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/04\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity.png","contentUrl":"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/04\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity.png","width":1200,"height":674},{"@type":"BreadcrumbList","@id":"https:\/\/www.threatshub.org\/blog\/exploitation-of-clfs-zero-day-leads-to-ransomware-activity\/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https:\/\/www.threatshub.org\/blog\/"},{"@type":"ListItem","position":2,"name":"Exploitation of CLFS zero-day leads to ransomware activity"}]},{"@type":"WebSite","@id":"https:\/\/www.threatshub.org\/blog\/#website","url":"https:\/\/www.threatshub.org\/blog\/","name":"ThreatsHub Cybersecurity News","description":"%%focuskw%% Threat Intel \u2013 Threat Intel Services \u2013 CyberIntelligence \u2013 Cyber Threat Intelligence - Threat Intelligence Feeds - Threat Intelligence Reports - CyberSecurity Report \u2013 Cyber Security PDF \u2013 Cybersecurity Trends - Cloud Sandbox \u2013- Threat IntelligencePortal \u2013 Incident Response \u2013 Threat Hunting \u2013 IOC - Yara - Security Operations Center \u2013 SecurityOperation Center \u2013 Security SOC \u2013 SOC Services - Advanced Threat - Threat Detection - TargetedAttack \u2013 APT \u2013 Anti-APT \u2013 Advanced Protection \u2013 Cyber Security Services \u2013 Cybersecurity Services -Threat Intelligence Platform","publisher":{"@id":"https:\/\/www.threatshub.org\/blog\/#organization"},"alternateName":"Threatshub.org","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https:\/\/www.threatshub.org\/blog\/?s={search_term_string}"},"query-input":{"@type":"PropertyValueSpecification","valueRequired":true,"valueName":"search_term_string"}}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https:\/\/www.threatshub.org\/blog\/#organization","name":"ThreatsHub.org","alternateName":"Threatshub.org","url":"https:\/\/www.threatshub.org\/blog\/","logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/www.threatshub.org\/blog\/#\/schema\/logo\/image\/","url":"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/05\/Threatshub_Favicon1.jpg","contentUrl":"https:\/\/www.threatshub.org\/blog\/coredata\/uploads\/2025\/05\/Threatshub_Favicon1.jpg","width":432,"height":435,"caption":"ThreatsHub.org"},"image":{"@id":"https:\/\/www.threatshub.org\/blog\/#\/schema\/logo\/image\/"},"sameAs":["https:\/\/x.com\/threatshub"]},{"@type":"Person","@id":"https:\/\/www.threatshub.org\/blog\/#\/schema\/person\/12e0a8671ff89a863584f193e7062476","name":"TH Author","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https:\/\/secure.gravatar.com\/avatar\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g","url":"https:\/\/secure.gravatar.com\/avatar\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g","contentUrl":"https:\/\/secure.gravatar.com\/avatar\/066276f086d5155df79c850206a779ad368418a844da0182ce43f9cd5b506c3d?s=96&d=mm&r=g","caption":"TH Author"}}]}},"_links":{"self":[{"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/posts\/58447","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/users\/2"}],"replies":[{"embeddable":true,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/comments?post=58447"}],"version-history":[{"count":0,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/posts\/58447\/revisions"}],"wp:featuredmedia":[{"embeddable":true,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/media\/58448"}],"wp:attachment":[{"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/media?parent=58447"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/categories?post=58447"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/www.threatshub.org\/blog\/wp-json\/wp\/v2\/tags?post=58447"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}